summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2018-12-26 12:56:42 +0100
committerMichał Górny <mgorny@gentoo.org>2018-12-26 14:34:23 +0100
commitfee47870046209fc5868f646e0dbfd89a9fc9b6b (patch)
treed104cea6405e591ddc963ec7cbaae4af83a6a00e /xfce-extra/xfce4-taskmanager/xfce4-taskmanager-1.2.2.ebuild
parentdev-util/meson: stable 0.48.2 for ia64, bug #672472 (diff)
downloadgentoo-fee47870046209fc5868f646e0dbfd89a9fc9b6b.tar.gz
gentoo-fee47870046209fc5868f646e0dbfd89a9fc9b6b.tar.bz2
gentoo-fee47870046209fc5868f646e0dbfd89a9fc9b6b.zip
xfce-extra/xfce4-taskmanager: Bump to 1.2.2, now GTK+3 by default
Bump to the new version which -- besides some bugfixes -- switches the default from GTK+2 to GTK+3. While GTK+2 is still technically supported, the configure bug requiring the default toolkit unconditionally has not been fixed, and upstream plans to remove GTK+2 support altogether in the next release. Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'xfce-extra/xfce4-taskmanager/xfce4-taskmanager-1.2.2.ebuild')
-rw-r--r--xfce-extra/xfce4-taskmanager/xfce4-taskmanager-1.2.2.ebuild45
1 files changed, 45 insertions, 0 deletions
diff --git a/xfce-extra/xfce4-taskmanager/xfce4-taskmanager-1.2.2.ebuild b/xfce-extra/xfce4-taskmanager/xfce4-taskmanager-1.2.2.ebuild
new file mode 100644
index 000000000000..12aa5a2754c0
--- /dev/null
+++ b/xfce-extra/xfce4-taskmanager/xfce4-taskmanager-1.2.2.ebuild
@@ -0,0 +1,45 @@
+# Copyright 1999-2018 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+inherit gnome2-utils
+
+DESCRIPTION="Easy to use task manager"
+HOMEPAGE="https://goodies.xfce.org/projects/applications/xfce4-taskmanager"
+SRC_URI="https://archive.xfce.org/src/apps/${PN}/${PV%.*}/${P}.tar.bz2"
+
+LICENSE="GPL-2+"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~ia64 ~ppc ~ppc64 ~sparc ~x86 ~x86-fbsd ~amd64-linux ~x86-linux"
+IUSE=""
+
+RDEPEND="
+ x11-libs/cairo:=
+ x11-libs/libX11:=
+ x11-libs/libXmu:=
+ x11-libs/gtk+:3=
+ x11-libs/libwnck:3="
+DEPEND="${RDEPEND}
+ dev-util/intltool
+ sys-devel/gettext
+ virtual/pkgconfig"
+
+src_configure() {
+ local myconf=(
+ --enable-wnck
+ # GTK+3 is required unconditionally anyway
+ --disable-gtk2
+ --disable-gksu
+ )
+
+ econf "${myconf[@]}"
+}
+
+pkg_postinst() {
+ gnome2_icon_cache_update
+}
+
+pkg_postrm() {
+ gnome2_icon_cache_update
+}