summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--dev-ml/ocplib-simplex/Manifest1
-rw-r--r--dev-ml/ocplib-simplex/ocplib-simplex-0.4.1.ebuild36
2 files changed, 37 insertions, 0 deletions
diff --git a/dev-ml/ocplib-simplex/Manifest b/dev-ml/ocplib-simplex/Manifest
index a1645db7e204..9ca9b54b0f34 100644
--- a/dev-ml/ocplib-simplex/Manifest
+++ b/dev-ml/ocplib-simplex/Manifest
@@ -1 +1,2 @@
+DIST ocplib-simplex-0.4.1.tar.gz 31955 BLAKE2B bddcf1f83dfd64fd7da3564cbb3fcb9f8e50ad4106ec03b6881315edd6106bb2f691dbe8f288121c351fa7e861fdddb9a818ce4527ab960a9c7109af49d97761 SHA512 6436a904f4e0ec4efa13592185764b58142296816855562d9c2c6d360b64ab554bbd95314976e0462fbb2ed145f8915fd9c2f63f7bae66063efb4c51f74f3edb
DIST ocplib-simplex-0.4.tar.gz 31784 BLAKE2B 89ebb43ba59debc658b1400b24379dcb717f44f484742a4ea2227e1692f2d1d359469add4e3c22bd15b7a5044e4d45877994b40e80f28ec8639989bf28565d9a SHA512 5eb80f0c8ad32291d24423255c0359e139cd85e2262b0cbbfaffcab66d9a7eb66c9bf04bb9d5d5c103574ec7041a72cde5412e6cb03fc9fe4a8fd257dab49a76
diff --git a/dev-ml/ocplib-simplex/ocplib-simplex-0.4.1.ebuild b/dev-ml/ocplib-simplex/ocplib-simplex-0.4.1.ebuild
new file mode 100644
index 000000000000..2f62b9e344e4
--- /dev/null
+++ b/dev-ml/ocplib-simplex/ocplib-simplex-0.4.1.ebuild
@@ -0,0 +1,36 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit autotools findlib
+
+DESCRIPTION="A library implementing a simplex algorithm"
+HOMEPAGE="https://github.com/OCamlPro-Iguernlala/ocplib-simplex"
+SRC_URI="https://github.com/OCamlPro-Iguernlala/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="LGPL-2.1-with-linking-exception"
+SLOT="0"
+KEYWORDS="~amd64"
+
+DOCS=( CHANGES.md README.md extra/simplex_invariants.txt extra/TODO.txt )
+
+PATCHES=(
+ "${FILESDIR}"/${PN}-0.4-flags.patch
+)
+
+QA_FLAGS_IGNORED=(
+ /usr/lib64/ocaml/ocplib-simplex/ocplibSimplex.cmxs
+)
+
+src_prepare() {
+ default
+ mv configure.{in,ac} || die
+ sed -i -e "s:configure.in:configure.ac:g" \
+ Makefile.in || die
+ eautoreconf
+}
+
+src_install() {
+ findlib_src_install LIBDIR="${D}"/usr/"$(get_libdir)"/ocaml
+}