summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-ml/ocplib-simplex/ocplib-simplex-0.4.1.ebuild')
-rw-r--r--dev-ml/ocplib-simplex/ocplib-simplex-0.4.1.ebuild36
1 files changed, 36 insertions, 0 deletions
diff --git a/dev-ml/ocplib-simplex/ocplib-simplex-0.4.1.ebuild b/dev-ml/ocplib-simplex/ocplib-simplex-0.4.1.ebuild
new file mode 100644
index 000000000000..2f62b9e344e4
--- /dev/null
+++ b/dev-ml/ocplib-simplex/ocplib-simplex-0.4.1.ebuild
@@ -0,0 +1,36 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit autotools findlib
+
+DESCRIPTION="A library implementing a simplex algorithm"
+HOMEPAGE="https://github.com/OCamlPro-Iguernlala/ocplib-simplex"
+SRC_URI="https://github.com/OCamlPro-Iguernlala/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="LGPL-2.1-with-linking-exception"
+SLOT="0"
+KEYWORDS="~amd64"
+
+DOCS=( CHANGES.md README.md extra/simplex_invariants.txt extra/TODO.txt )
+
+PATCHES=(
+ "${FILESDIR}"/${PN}-0.4-flags.patch
+)
+
+QA_FLAGS_IGNORED=(
+ /usr/lib64/ocaml/ocplib-simplex/ocplibSimplex.cmxs
+)
+
+src_prepare() {
+ default
+ mv configure.{in,ac} || die
+ sed -i -e "s:configure.in:configure.ac:g" \
+ Makefile.in || die
+ eautoreconf
+}
+
+src_install() {
+ findlib_src_install LIBDIR="${D}"/usr/"$(get_libdir)"/ocaml
+}