summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--dev-ros/roscpp/Manifest1
-rw-r--r--dev-ros/roscpp/roscpp-1.15.8.ebuild30
2 files changed, 31 insertions, 0 deletions
diff --git a/dev-ros/roscpp/Manifest b/dev-ros/roscpp/Manifest
index 5d86517495e4..adf4f2af1194 100644
--- a/dev-ros/roscpp/Manifest
+++ b/dev-ros/roscpp/Manifest
@@ -1 +1,2 @@
DIST ros_comm-1.15.7.tar.gz 1080092 BLAKE2B d5c0dd1f54eac7aa11be21bbc680f85f988cc9328382c0c675b7d5986e888be603ed82affa5f51a270974d07044debe3ecf86f5647fd59cb29e8e791a227feb9 SHA512 67dc100e8ed03a25ea228cc7d456ec2203324098f9e11c9a249299df73bfc34efc75b1221c0fb6fceb38fece627f1dc5f2c23be93c9a1c85b1075784a45ff20e
+DIST ros_comm-1.15.8.tar.gz 1080826 BLAKE2B c1a1e085225a96cf0b50309cb78e1ccdabefce1f23ee669393b7fc747537c7e39bfb6ad382b0d24e3b5507b1d0f3eaf2051a1bee90507b0e724e06a83df301a2 SHA512 b1c34ab6548400fc014eda496e5d1e1c7d134b9062a031386ac4eac3245ca83b034f74f0a189ccf9ec6933c18d6df0ae1a93d05f1526d09debf70c25aa25b6b9
diff --git a/dev-ros/roscpp/roscpp-1.15.8.ebuild b/dev-ros/roscpp/roscpp-1.15.8.ebuild
new file mode 100644
index 000000000000..8863bf3d38b4
--- /dev/null
+++ b/dev-ros/roscpp/roscpp-1.15.8.ebuild
@@ -0,0 +1,30 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+ROS_REPO_URI="https://github.com/ros/ros_comm"
+KEYWORDS="~amd64 ~arm"
+CATKIN_HAS_MESSAGES=yes
+ROS_SUBDIR=clients/${PN}
+
+inherit ros-catkin
+
+DESCRIPTION="C++ implementation of ROS"
+LICENSE="BSD"
+SLOT="0"
+IUSE=""
+
+RDEPEND="
+ dev-ros/cpp_common
+ dev-ros/rosconsole
+ dev-ros/roscpp_serialization
+ dev-ros/roscpp_traits
+ dev-ros/rostime
+ dev-ros/xmlrpcpp
+ dev-libs/boost:=
+ dev-ros/std_msgs[${CATKIN_MESSAGES_CXX_USEDEP}]
+ dev-ros/rosgraph_msgs[${CATKIN_MESSAGES_CXX_USEDEP}]
+"
+DEPEND="${RDEPEND}"
+PATCHES=( "${FILESDIR}/boost173.patch" )