summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--dev-python/stdio-mgr/Manifest1
-rw-r--r--dev-python/stdio-mgr/stdio-mgr-1.0.1.ebuild32
2 files changed, 0 insertions, 33 deletions
diff --git a/dev-python/stdio-mgr/Manifest b/dev-python/stdio-mgr/Manifest
index 938131f9cd59..b918f04bf9d9 100644
--- a/dev-python/stdio-mgr/Manifest
+++ b/dev-python/stdio-mgr/Manifest
@@ -1,2 +1 @@
DIST stdio-mgr-1.0.1.gh.tar.gz 8447 BLAKE2B 72038ea34177829d77ac239585775557b5a0a253879c027b2aad64045ec8bafbfdc250d94fe61cde96f06616f774edf42b384bfef7fbf69af442b0a9b703cf9a SHA512 2d18e5d65faa7a73373b56fdac3893768a65a36bed17f017b647e71431a6bff44ce1d39022f1dbbd31ddc9c0e704743a164f4b7610fb62d75aa34ecb53331366
-DIST stdio-mgr-1.0.1.tar.gz 8447 BLAKE2B 72038ea34177829d77ac239585775557b5a0a253879c027b2aad64045ec8bafbfdc250d94fe61cde96f06616f774edf42b384bfef7fbf69af442b0a9b703cf9a SHA512 2d18e5d65faa7a73373b56fdac3893768a65a36bed17f017b647e71431a6bff44ce1d39022f1dbbd31ddc9c0e704743a164f4b7610fb62d75aa34ecb53331366
diff --git a/dev-python/stdio-mgr/stdio-mgr-1.0.1.ebuild b/dev-python/stdio-mgr/stdio-mgr-1.0.1.ebuild
deleted file mode 100644
index b5546da434ca..000000000000
--- a/dev-python/stdio-mgr/stdio-mgr-1.0.1.ebuild
+++ /dev/null
@@ -1,32 +0,0 @@
-# Copyright 1999-2023 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=7
-
-PYTHON_COMPAT=( python3_{9..11} )
-
-inherit distutils-r1
-
-DESCRIPTION="Context manager for mocking/wrapping stdin/stdout/stderr"
-HOMEPAGE="
- https://github.com/bskinn/stdio-mgr/
- https://pypi.org/project/stdio-mgr/
-"
-SRC_URI="https://github.com/bskinn/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
-
-LICENSE="MIT"
-KEYWORDS="~alpha amd64 arm arm64 ~hppa ~ia64 ~mips ppc ppc64 ~riscv ~s390 sparc x86"
-SLOT="0"
-
-RDEPEND=">=dev-python/attrs-17.1[${PYTHON_USEDEP}]"
-
-distutils_enable_tests pytest
-# doc directory is not included in the release tarball for some reason
-#distutils_enable_sphinx doc \
-# dev-python/sphinxcontrib-programoutput \
-# dev-python/sphinx-rtd-theme
-
-python_test() {
- # skip the doctests
- epytest tests
-}