summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/stdio-mgr/stdio-mgr-1.0.1.ebuild')
-rw-r--r--dev-python/stdio-mgr/stdio-mgr-1.0.1.ebuild32
1 files changed, 0 insertions, 32 deletions
diff --git a/dev-python/stdio-mgr/stdio-mgr-1.0.1.ebuild b/dev-python/stdio-mgr/stdio-mgr-1.0.1.ebuild
deleted file mode 100644
index b5546da434ca..000000000000
--- a/dev-python/stdio-mgr/stdio-mgr-1.0.1.ebuild
+++ /dev/null
@@ -1,32 +0,0 @@
-# Copyright 1999-2023 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=7
-
-PYTHON_COMPAT=( python3_{9..11} )
-
-inherit distutils-r1
-
-DESCRIPTION="Context manager for mocking/wrapping stdin/stdout/stderr"
-HOMEPAGE="
- https://github.com/bskinn/stdio-mgr/
- https://pypi.org/project/stdio-mgr/
-"
-SRC_URI="https://github.com/bskinn/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
-
-LICENSE="MIT"
-KEYWORDS="~alpha amd64 arm arm64 ~hppa ~ia64 ~mips ppc ppc64 ~riscv ~s390 sparc x86"
-SLOT="0"
-
-RDEPEND=">=dev-python/attrs-17.1[${PYTHON_USEDEP}]"
-
-distutils_enable_tests pytest
-# doc directory is not included in the release tarball for some reason
-#distutils_enable_sphinx doc \
-# dev-python/sphinxcontrib-programoutput \
-# dev-python/sphinx-rtd-theme
-
-python_test() {
- # skip the doctests
- epytest tests
-}