summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--sci-biology/STAR/Manifest1
-rw-r--r--sci-biology/STAR/STAR-2.7.10a.ebuild41
2 files changed, 42 insertions, 0 deletions
diff --git a/sci-biology/STAR/Manifest b/sci-biology/STAR/Manifest
index 35d580101e14..d8457898903d 100644
--- a/sci-biology/STAR/Manifest
+++ b/sci-biology/STAR/Manifest
@@ -1 +1,2 @@
DIST STAR-2.5.3a.tar.gz 9857460 BLAKE2B 32cc633862e6e81f5a5bdfc59986dca74e8adc4970a11a06c501065c5ad9cb37fc788f8e67ab2353292e683c8c385778cd0ffee69c0b15803796dbc445013a43 SHA512 8bd86ad384f2c0331fd701873b02641301f4205a5ff0fceeb800d425da42c53b6c61a74500d37fee7fc13a5bff10e1fb44b9142811883b8f5cd012f51f1f9fdf
+DIST STAR-2.7.10a.tar.gz 12270915 BLAKE2B 51a9cf2c838cfeb313df9e5024b53cd5a89088f08ac88c8dc57a9e08cd3ba394e46ffe86a8ff3b9484b25b681ecd960098c06d879e772d21afe8cc2d0d35175d SHA512 19a5f3c25d147bcd96cf68249d275dad7fd11425031a40c97c7ae15846f55839ced897d541ed60b426a6bf089d968ac86625af774db3950dc459035ac2b659c9
diff --git a/sci-biology/STAR/STAR-2.7.10a.ebuild b/sci-biology/STAR/STAR-2.7.10a.ebuild
new file mode 100644
index 000000000000..6b1c5b15d482
--- /dev/null
+++ b/sci-biology/STAR/STAR-2.7.10a.ebuild
@@ -0,0 +1,41 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit toolchain-funcs
+
+DESCRIPTION="STAR aligner: align RNA-seq reads to reference genome uncompressed suffix arrays"
+HOMEPAGE="https://github.com/alexdobin/STAR"
+SRC_URI="https://github.com/alexdobin/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64"
+
+RDEPEND="sci-libs/htslib:="
+DEPEND="${RDEPEND}"
+BDEPEND="virtual/pkgconfig"
+
+DOCS=( README.md CHANGES.md RELEASEnotes.md doc/STARmanual.pdf )
+
+pkg_pretend() {
+ [[ ${MERGE_TYPE} != binary ]] && tc-check-openmp
+}
+
+pkg_setup() {
+ [[ ${MERGE_TYPE} != binary ]] && tc-check-openmp
+}
+
+src_configure() {
+ tc-export CC CXX PKG_CONFIG
+}
+
+src_compile() {
+ emake -C source STAR
+}
+
+src_install() {
+ dobin source/STAR
+ einstalldocs
+}