summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--xfce-extra/xfce4-cpufreq-plugin/Manifest1
-rw-r--r--xfce-extra/xfce4-cpufreq-plugin/xfce4-cpufreq-plugin-1.2.8.ebuild46
2 files changed, 47 insertions, 0 deletions
diff --git a/xfce-extra/xfce4-cpufreq-plugin/Manifest b/xfce-extra/xfce4-cpufreq-plugin/Manifest
index 88a449842536..e7226464c8ef 100644
--- a/xfce-extra/xfce4-cpufreq-plugin/Manifest
+++ b/xfce-extra/xfce4-cpufreq-plugin/Manifest
@@ -1 +1,2 @@
DIST xfce4-cpufreq-plugin-1.2.7.tar.bz2 446055 BLAKE2B bedcf4ece6f1696a13144b0dd9d28a9dfdda255ed72f3b7aa7d572fd33b718a01850aaac90887b79ca57e4a7a9e4a6b234ac880e3a180a459e54c8377da3a9b9 SHA512 6bb7f5790d3ba9756afcb47cde40420453afe191fa111e390f2ad9780f3ab51ac2c6a69586303e9a5d1fb7d1af3eda3dad93f10df072f9ae59e47fc2216db434
+DIST xfce4-cpufreq-plugin-1.2.8.tar.bz2 431599 BLAKE2B f08d27b2461e3ac387dc139231a8febb6239fe8e5132ef89a6d4a8f9009fb7a3dd011ead97f27872fbb4857fc563e65fc2dd6e0f652d8d7299d3c9966d6f8b57 SHA512 482912920703b61ccba59b1a95a4153d06a7c897a59d7c2e5f84f6ea1cac17be2bade72d9187fc62279112f41cd2dd3f3157df31fae165eb2a104b74fec310da
diff --git a/xfce-extra/xfce4-cpufreq-plugin/xfce4-cpufreq-plugin-1.2.8.ebuild b/xfce-extra/xfce4-cpufreq-plugin/xfce4-cpufreq-plugin-1.2.8.ebuild
new file mode 100644
index 000000000000..9c4b3d67d7a6
--- /dev/null
+++ b/xfce-extra/xfce4-cpufreq-plugin/xfce4-cpufreq-plugin-1.2.8.ebuild
@@ -0,0 +1,46 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit xdg-utils
+
+DESCRIPTION="A panel plugin for showing information about cpufreq settings"
+HOMEPAGE="
+ https://docs.xfce.org/panel-plugins/xfce4-cpufreq-plugin/start
+ https://gitlab.xfce.org/panel-plugins/xfce4-cpufreq-plugin/
+"
+SRC_URI="https://archive.xfce.org/src/panel-plugins/${PN}/${PV%.*}/${P}.tar.bz2"
+
+LICENSE="GPL-2+"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~ppc ~ppc64 ~riscv ~x86"
+
+DEPEND="
+ >=dev-libs/glib-2.20
+ >=x11-libs/gtk+-3.20:3
+ >=xfce-base/libxfce4ui-4.16:=
+ >=xfce-base/libxfce4util-4.17.2:=
+ >=xfce-base/xfce4-panel-4.16:=
+"
+RDEPEND="
+ ${DEPEND}
+"
+BDEPEND="
+ dev-util/intltool
+ sys-devel/gettext
+ virtual/pkgconfig
+"
+
+src_install() {
+ default
+ find "${D}" -name '*.la' -delete || die
+}
+
+pkg_postinst() {
+ xdg_icon_cache_update
+}
+
+pkg_postrm() {
+ xdg_icon_cache_update
+}