summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'xfce-extra/xfce4-cpufreq-plugin/xfce4-cpufreq-plugin-1.2.8.ebuild')
-rw-r--r--xfce-extra/xfce4-cpufreq-plugin/xfce4-cpufreq-plugin-1.2.8.ebuild46
1 files changed, 46 insertions, 0 deletions
diff --git a/xfce-extra/xfce4-cpufreq-plugin/xfce4-cpufreq-plugin-1.2.8.ebuild b/xfce-extra/xfce4-cpufreq-plugin/xfce4-cpufreq-plugin-1.2.8.ebuild
new file mode 100644
index 000000000000..9c4b3d67d7a6
--- /dev/null
+++ b/xfce-extra/xfce4-cpufreq-plugin/xfce4-cpufreq-plugin-1.2.8.ebuild
@@ -0,0 +1,46 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit xdg-utils
+
+DESCRIPTION="A panel plugin for showing information about cpufreq settings"
+HOMEPAGE="
+ https://docs.xfce.org/panel-plugins/xfce4-cpufreq-plugin/start
+ https://gitlab.xfce.org/panel-plugins/xfce4-cpufreq-plugin/
+"
+SRC_URI="https://archive.xfce.org/src/panel-plugins/${PN}/${PV%.*}/${P}.tar.bz2"
+
+LICENSE="GPL-2+"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~ppc ~ppc64 ~riscv ~x86"
+
+DEPEND="
+ >=dev-libs/glib-2.20
+ >=x11-libs/gtk+-3.20:3
+ >=xfce-base/libxfce4ui-4.16:=
+ >=xfce-base/libxfce4util-4.17.2:=
+ >=xfce-base/xfce4-panel-4.16:=
+"
+RDEPEND="
+ ${DEPEND}
+"
+BDEPEND="
+ dev-util/intltool
+ sys-devel/gettext
+ virtual/pkgconfig
+"
+
+src_install() {
+ default
+ find "${D}" -name '*.la' -delete || die
+}
+
+pkg_postinst() {
+ xdg_icon_cache_update
+}
+
+pkg_postrm() {
+ xdg_icon_cache_update
+}