summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--dev-java/jackson-annotations/Manifest1
-rw-r--r--dev-java/jackson-annotations/jackson-annotations-2.13.4.ebuild38
2 files changed, 39 insertions, 0 deletions
diff --git a/dev-java/jackson-annotations/Manifest b/dev-java/jackson-annotations/Manifest
index 63bfb41a2979..72572870ca8c 100644
--- a/dev-java/jackson-annotations/Manifest
+++ b/dev-java/jackson-annotations/Manifest
@@ -1 +1,2 @@
DIST jackson-annotations-2.13.3.tar.gz 1984205 BLAKE2B c577fcdcb40c44cf1cb08ebe467318ca4e4fff9fdeaf756360ef202275a48b5f5a93135439567261651b5731f523588f0c29a17c05ba6d03fec0f19ed19d9c5b SHA512 c00aec542c8ddea999fb60536cb2cab3edbf4f1d20b29e404d62add54a22546ca195ab7faeda4a2cd1d3a827f10420ccafe1dfb0065742f46aecfc2d00f2c1fc
+DIST jackson-annotations-2.13.4.tar.gz 1984001 BLAKE2B 8c4eed89fc0c5b3d68f25f2db28a38e55a2e629c7c38289a82f4ff4a122967326e0221cb020afb69577fe4d5baa2ba89f8db5a398302cd25404083a5d0830eaf SHA512 5ad1d07b254956f9d4123eb01e32d8a8f43eccefe60c6841675ccfecd8837feb4de9352d90f8b8a2703f0f12a0fd20083f8d274594e1ca5674894b2cd76ce322
diff --git a/dev-java/jackson-annotations/jackson-annotations-2.13.4.ebuild b/dev-java/jackson-annotations/jackson-annotations-2.13.4.ebuild
new file mode 100644
index 000000000000..c4e28ae651e0
--- /dev/null
+++ b/dev-java/jackson-annotations/jackson-annotations-2.13.4.ebuild
@@ -0,0 +1,38 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+# Skeleton command:
+# java-ebuilder --generate-ebuild --workdir . --pom pom.xml --download-uri https://github.com/FasterXML/jackson-annotations/archive/jackson-annotations-2.13.4.tar.gz --slot 2 --keywords "~amd64 ~arm ~arm64 ~ppc64 ~x86" --ebuild jackson-annotations-2.13.4.ebuild
+
+EAPI=8
+
+JAVA_PKG_IUSE="doc source test"
+MAVEN_ID="com.fasterxml.jackson.core:jackson-annotations:2.13.4"
+JAVA_TESTING_FRAMEWORKS="junit-4"
+
+inherit java-pkg-2 java-pkg-simple
+
+DESCRIPTION="Core annotations used for value types, used by Jackson data binding package."
+HOMEPAGE="https://github.com/FasterXML/jackson-annotations"
+SRC_URI="https://github.com/FasterXML/${PN}/archive/${P}.tar.gz"
+
+LICENSE="Apache-2.0"
+SLOT="2"
+KEYWORDS="~amd64 ~arm ~arm64 ~ppc64 ~x86"
+
+DEPEND=">=virtual/jdk-11:*"
+RDEPEND=">=virtual/jre-1.8:*"
+
+DOCS=( {README,SECURITY}.md release-notes/VERSION-2.x )
+
+S="${WORKDIR}/${PN}-${P}"
+
+JAVA_SRC_DIR=( "src/main/java" "src/moditect" )
+
+JAVA_TEST_GENTOO_CLASSPATH="junit-4"
+JAVA_TEST_SRC_DIR="src/test/java"
+JAVA_TEST_EXCLUDES=(
+ # 1) warning(junit.framework.TestSuite$1)
+ # junit.framework.AssertionFailedError: No tests found in com.fasterxml.jackson.annotation.TestBase
+ com.fasterxml.jackson.annotation.TestBase
+)