summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--dev-python/pyphen/Manifest1
-rw-r--r--dev-python/pyphen/pyphen-0.9.5.ebuild30
2 files changed, 31 insertions, 0 deletions
diff --git a/dev-python/pyphen/Manifest b/dev-python/pyphen/Manifest
index 9ec4f8bce627..83d3afe149a2 100644
--- a/dev-python/pyphen/Manifest
+++ b/dev-python/pyphen/Manifest
@@ -1 +1,2 @@
DIST Pyphen-0.9.4.tar.gz 1092404 BLAKE2B 9bd96c0d0dc7a7ccb9bebaf7e864ec0212956ac910830d9a3286fc9569d9b044f7aedbc3d807260e5b5e1ccbe84ffa22c686680ebf7352cd23d6ed2755f7d92e SHA512 b48dcf02c5cdf5d7ee6d6968644958af9f31fba046612016d9ae1b8cfe44d438fe769592961f93f3342cc3f3af2dfc6cd40bbfe1be67e59de9a352c33f102917
+DIST pyphen-0.9.5.tar.gz 1901384 BLAKE2B 809f7e3c204ab7de87a387909fb0d9aebd3d48586a6b1da8a683a8b1f862e2d2489babfb30c9792acca44c0fe7bd5da39c1508245ec784dce30a4c7124e91152 SHA512 049a62b226e90e568c8f56e756f8fa6fbc74f3bc40d61af8eb05ff2d4404a7b29cef14d4f144d68ed2f2b11eb128491de64536240ba7b76a2d04010c76e10346
diff --git a/dev-python/pyphen/pyphen-0.9.5.ebuild b/dev-python/pyphen/pyphen-0.9.5.ebuild
new file mode 100644
index 000000000000..ea8a50eaa3d8
--- /dev/null
+++ b/dev-python/pyphen/pyphen-0.9.5.ebuild
@@ -0,0 +1,30 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI="7"
+PYTHON_COMPAT=( python3_{6,7,8} )
+
+DISTUTILS_USE_SETUPTOOLS=bdepend
+inherit distutils-r1
+
+DESCRIPTION="Python module for hyphenation using hunspell dictionaries"
+MY_PN="Pyphen"
+MY_P="${MY_PN}-${PV}"
+SRC_URI="https://github.com/Kozea/${MY_PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
+HOMEPAGE="https://github.com/Kozea/Pyphen"
+
+LICENSE="GPL-2+ LGPL-2+ MPL-1.1"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+RDEPEND=""
+DEPEND="test? ( dev-python/pytest[${PYTHON_USEDEP}] )"
+
+S="${WORKDIR}/${MY_P}"
+
+distutils_enable_tests pytest
+
+python_test() {
+ pytest -v test.py || die
+}