summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--dev-python/zipp/Manifest3
-rw-r--r--dev-python/zipp/zipp-3.15.0.ebuild52
-rw-r--r--dev-python/zipp/zipp-3.16.0.ebuild52
-rw-r--r--dev-python/zipp/zipp-3.16.1.ebuild52
4 files changed, 0 insertions, 159 deletions
diff --git a/dev-python/zipp/Manifest b/dev-python/zipp/Manifest
index 84a81625dcd1..826e143abe79 100644
--- a/dev-python/zipp/Manifest
+++ b/dev-python/zipp/Manifest
@@ -1,4 +1 @@
-DIST zipp-3.15.0.tar.gz 18454 BLAKE2B 759c9be6cdf6297874ed8d7cc98e8fc7c360bb765b72b345b264034f43a63831b92daa31a4d40736cc83a12b5f853d17da7fae290cb62a87ac6552edfcaca913 SHA512 74a512428fa29e284c515a7e6c45030e4d840727e12e376bca480a90b7fd1e111462deafa372ca9aebd9f53c24bc37111570e7a4a6a873c0b7dee9a0277c100d
-DIST zipp-3.16.0.tar.gz 18432 BLAKE2B b9f9f016f6f6bc87610fa4338dcbd237b09623cb5da20761e5a6f4e06bc694b6e5fd219681e12468b76b2ebf590f3ea1adfa066dfdf49caf4aecee30f73a4c19 SHA512 f83eb32a28a1f3acf49ade075e8390f89912d1a058cf514432c06efc1963d2a40d78051a6f7963fcdaee3dcf38e327a48a4eef15e5f3ac0db4a9590d6061ccdf
-DIST zipp-3.16.1.tar.gz 19194 BLAKE2B 7428764465674f356881d91216386c8f8495f613d7b0e457bbd77e662b958aae7d2fff65afb8afbfadbe31285edd26858272f1501a27f7378dea3b8b866922df SHA512 e1f8d03c8b8c49e4745e03b65e32c9b76bb4e7c87e24304af630e8875843ad4cfc12f46f5dce3f210698a9e9a5f58be251eafed83893128657d8cb23c11066d0
DIST zipp-3.16.2.tar.gz 20002 BLAKE2B abc9b9b2c801f50856e6ad761ff2be81729a475e221716b63c8e017ae87b5f712e43547ba1a42911533f9ad88d02e805768e5bcba397b3f7355d0a8cdcbaab0a SHA512 cb7f19638b2bc2bb1c38241078836c4e484b8f1fae8232073da25967f01e449eb8a6c870d2afde285ea9ae319785a9e4b7cb0e5edc2d0f4690f3ce27c359be93
diff --git a/dev-python/zipp/zipp-3.15.0.ebuild b/dev-python/zipp/zipp-3.15.0.ebuild
deleted file mode 100644
index c25ebf7be46a..000000000000
--- a/dev-python/zipp/zipp-3.15.0.ebuild
+++ /dev/null
@@ -1,52 +0,0 @@
-# Copyright 1999-2023 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-# please keep this ebuild at EAPI 7 -- sys-apps/portage dep
-EAPI=7
-
-DISTUTILS_USE_PEP517=flit
-PYTHON_COMPAT=( pypy3 python3_{9..12} )
-
-inherit distutils-r1 pypi
-
-DESCRIPTION="Backport of pathlib-compatible object wrapper for zip files"
-HOMEPAGE="
- https://github.com/jaraco/zipp/
- https://pypi.org/project/zipp/
-"
-
-LICENSE="MIT"
-SLOT="0"
-KEYWORDS="~alpha amd64 arm arm64 hppa ~ia64 ~loong ~m68k ~mips ppc ppc64 ~riscv ~s390 sparc x86 ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x64-solaris"
-
-# big_o is only used in test_complexity, that we ignore
-BDEPEND="
- test? (
- dev-python/jaraco-functools[${PYTHON_USEDEP}]
- dev-python/jaraco-itertools[${PYTHON_USEDEP}]
- dev-python/more-itertools[${PYTHON_USEDEP}]
- )
-"
-
-distutils_enable_tests pytest
-
-EPYTEST_IGNORE=(
- # performance tests are flaky by design
- tests/test_complexity.py
-)
-
-src_configure() {
- grep -q 'build-backend = "setuptools' pyproject.toml ||
- die "Upstream changed build-backend, recheck"
- # write a custom pyproject.toml to ease setuptools bootstrap
- cat > pyproject.toml <<-EOF || die
- [build-system]
- requires = ["flit_core >=3.2,<4"]
- build-backend = "flit_core.buildapi"
-
- [project]
- name = "zipp"
- version = "${PV}"
- description = "Backport of pathlib-compatible object wrapper for zip files"
- EOF
-}
diff --git a/dev-python/zipp/zipp-3.16.0.ebuild b/dev-python/zipp/zipp-3.16.0.ebuild
deleted file mode 100644
index b9d1c493d482..000000000000
--- a/dev-python/zipp/zipp-3.16.0.ebuild
+++ /dev/null
@@ -1,52 +0,0 @@
-# Copyright 1999-2023 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-# please keep this ebuild at EAPI 7 -- sys-apps/portage dep
-EAPI=7
-
-DISTUTILS_USE_PEP517=flit
-PYTHON_COMPAT=( pypy3 python3_{10..12} )
-
-inherit distutils-r1 pypi
-
-DESCRIPTION="Backport of pathlib-compatible object wrapper for zip files"
-HOMEPAGE="
- https://github.com/jaraco/zipp/
- https://pypi.org/project/zipp/
-"
-
-LICENSE="MIT"
-SLOT="0"
-KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~loong ~m68k ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x64-solaris"
-
-# big_o is only used in test_complexity, that we ignore
-BDEPEND="
- test? (
- dev-python/jaraco-functools[${PYTHON_USEDEP}]
- dev-python/jaraco-itertools[${PYTHON_USEDEP}]
- dev-python/more-itertools[${PYTHON_USEDEP}]
- )
-"
-
-distutils_enable_tests pytest
-
-EPYTEST_IGNORE=(
- # performance tests are flaky by design
- tests/test_complexity.py
-)
-
-src_configure() {
- grep -q 'build-backend = "setuptools' pyproject.toml ||
- die "Upstream changed build-backend, recheck"
- # write a custom pyproject.toml to ease setuptools bootstrap
- cat > pyproject.toml <<-EOF || die
- [build-system]
- requires = ["flit_core >=3.2,<4"]
- build-backend = "flit_core.buildapi"
-
- [project]
- name = "zipp"
- version = "${PV}"
- description = "Backport of pathlib-compatible object wrapper for zip files"
- EOF
-}
diff --git a/dev-python/zipp/zipp-3.16.1.ebuild b/dev-python/zipp/zipp-3.16.1.ebuild
deleted file mode 100644
index b9d1c493d482..000000000000
--- a/dev-python/zipp/zipp-3.16.1.ebuild
+++ /dev/null
@@ -1,52 +0,0 @@
-# Copyright 1999-2023 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-# please keep this ebuild at EAPI 7 -- sys-apps/portage dep
-EAPI=7
-
-DISTUTILS_USE_PEP517=flit
-PYTHON_COMPAT=( pypy3 python3_{10..12} )
-
-inherit distutils-r1 pypi
-
-DESCRIPTION="Backport of pathlib-compatible object wrapper for zip files"
-HOMEPAGE="
- https://github.com/jaraco/zipp/
- https://pypi.org/project/zipp/
-"
-
-LICENSE="MIT"
-SLOT="0"
-KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~loong ~m68k ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x64-solaris"
-
-# big_o is only used in test_complexity, that we ignore
-BDEPEND="
- test? (
- dev-python/jaraco-functools[${PYTHON_USEDEP}]
- dev-python/jaraco-itertools[${PYTHON_USEDEP}]
- dev-python/more-itertools[${PYTHON_USEDEP}]
- )
-"
-
-distutils_enable_tests pytest
-
-EPYTEST_IGNORE=(
- # performance tests are flaky by design
- tests/test_complexity.py
-)
-
-src_configure() {
- grep -q 'build-backend = "setuptools' pyproject.toml ||
- die "Upstream changed build-backend, recheck"
- # write a custom pyproject.toml to ease setuptools bootstrap
- cat > pyproject.toml <<-EOF || die
- [build-system]
- requires = ["flit_core >=3.2,<4"]
- build-backend = "flit_core.buildapi"
-
- [project]
- name = "zipp"
- version = "${PV}"
- description = "Backport of pathlib-compatible object wrapper for zip files"
- EOF
-}