summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/zipp/zipp-3.16.1.ebuild')
-rw-r--r--dev-python/zipp/zipp-3.16.1.ebuild52
1 files changed, 0 insertions, 52 deletions
diff --git a/dev-python/zipp/zipp-3.16.1.ebuild b/dev-python/zipp/zipp-3.16.1.ebuild
deleted file mode 100644
index b9d1c493d482..000000000000
--- a/dev-python/zipp/zipp-3.16.1.ebuild
+++ /dev/null
@@ -1,52 +0,0 @@
-# Copyright 1999-2023 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-# please keep this ebuild at EAPI 7 -- sys-apps/portage dep
-EAPI=7
-
-DISTUTILS_USE_PEP517=flit
-PYTHON_COMPAT=( pypy3 python3_{10..12} )
-
-inherit distutils-r1 pypi
-
-DESCRIPTION="Backport of pathlib-compatible object wrapper for zip files"
-HOMEPAGE="
- https://github.com/jaraco/zipp/
- https://pypi.org/project/zipp/
-"
-
-LICENSE="MIT"
-SLOT="0"
-KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~loong ~m68k ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x64-solaris"
-
-# big_o is only used in test_complexity, that we ignore
-BDEPEND="
- test? (
- dev-python/jaraco-functools[${PYTHON_USEDEP}]
- dev-python/jaraco-itertools[${PYTHON_USEDEP}]
- dev-python/more-itertools[${PYTHON_USEDEP}]
- )
-"
-
-distutils_enable_tests pytest
-
-EPYTEST_IGNORE=(
- # performance tests are flaky by design
- tests/test_complexity.py
-)
-
-src_configure() {
- grep -q 'build-backend = "setuptools' pyproject.toml ||
- die "Upstream changed build-backend, recheck"
- # write a custom pyproject.toml to ease setuptools bootstrap
- cat > pyproject.toml <<-EOF || die
- [build-system]
- requires = ["flit_core >=3.2,<4"]
- build-backend = "flit_core.buildapi"
-
- [project]
- name = "zipp"
- version = "${PV}"
- description = "Backport of pathlib-compatible object wrapper for zip files"
- EOF
-}