summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--games-util/nml/Manifest1
-rw-r--r--games-util/nml/nml-0.4.5.ebuild27
2 files changed, 28 insertions, 0 deletions
diff --git a/games-util/nml/Manifest b/games-util/nml/Manifest
index 86d71231e195..32a52b50b610 100644
--- a/games-util/nml/Manifest
+++ b/games-util/nml/Manifest
@@ -1 +1,2 @@
DIST nml-0.4.4.tar.gz 377998 BLAKE2B a65df2c371c1b1dda2469a968372f21f9f27e9739c8d8a9a0f582c126169921ee3ffc9745f6ef4ac21aebdeea35fd26385d3149e84d50381c4796b71b378571f SHA512 fd7b8d7abfc8b5ea694eedf00bbc4069a82de942178a58ec05e9d3efe7c8663103ffb6b98f7614ce165eb7cba42cb4c7589f77fb67dd95eb6293f62b3179c7b0
+DIST nml-0.4.5.tar.gz 378578 BLAKE2B 1283cdcabd4cbaf12dda926b89c88a3942e9e4469879812abe372facd2c41ff20af0df792bbdadf71d9d3ad8d72e98e293fd903c880e77d3e4ee8a1b73e36ca9 SHA512 64b2f46a1c2e37fce8f51231094e30334f368b0db39c6a3977a144a798d8034d1abbe7c14af3921eb81f4b7caa193e7e53ccb9e27acd113e0407926b109ca952
diff --git a/games-util/nml/nml-0.4.5.ebuild b/games-util/nml/nml-0.4.5.ebuild
new file mode 100644
index 000000000000..ce56b6ea5532
--- /dev/null
+++ b/games-util/nml/nml-0.4.5.ebuild
@@ -0,0 +1,27 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+PYTHON_COMPAT=( python3_{4,5,6} )
+inherit distutils-r1
+
+DESCRIPTION="Compiler of NML files into grf/nfo files"
+HOMEPAGE="https://dev.openttdcoop.org/projects/nml"
+SRC_URI="http://bundles.openttdcoop.org/nml/releases/${PV}/${P}.tar.gz"
+
+LICENSE="GPL-2+"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~x86"
+
+RDEPEND="dev-python/pillow[zlib,${PYTHON_USEDEP}]
+ dev-python/ply[${PYTHON_USEDEP}]"
+DEPEND="${RDEPEND}
+ dev-python/setuptools[${PYTHON_USEDEP}]"
+
+DOCS=( docs/{changelog,readme}.txt )
+PATCHES=( "${FILESDIR}"/${PN}-0.4.4-pillow3.patch )
+
+src_install() {
+ distutils-r1_src_install
+ doman docs/nmlc.1
+}