summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'games-util/nml/nml-0.4.5.ebuild')
-rw-r--r--games-util/nml/nml-0.4.5.ebuild27
1 files changed, 27 insertions, 0 deletions
diff --git a/games-util/nml/nml-0.4.5.ebuild b/games-util/nml/nml-0.4.5.ebuild
new file mode 100644
index 000000000000..ce56b6ea5532
--- /dev/null
+++ b/games-util/nml/nml-0.4.5.ebuild
@@ -0,0 +1,27 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+PYTHON_COMPAT=( python3_{4,5,6} )
+inherit distutils-r1
+
+DESCRIPTION="Compiler of NML files into grf/nfo files"
+HOMEPAGE="https://dev.openttdcoop.org/projects/nml"
+SRC_URI="http://bundles.openttdcoop.org/nml/releases/${PV}/${P}.tar.gz"
+
+LICENSE="GPL-2+"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~x86"
+
+RDEPEND="dev-python/pillow[zlib,${PYTHON_USEDEP}]
+ dev-python/ply[${PYTHON_USEDEP}]"
+DEPEND="${RDEPEND}
+ dev-python/setuptools[${PYTHON_USEDEP}]"
+
+DOCS=( docs/{changelog,readme}.txt )
+PATCHES=( "${FILESDIR}"/${PN}-0.4.4-pillow3.patch )
+
+src_install() {
+ distutils-r1_src_install
+ doman docs/nmlc.1
+}