summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--dev-python/guessit/guessit-3.0.0.ebuild14
-rw-r--r--dev-python/guessit/guessit-9999.ebuild14
2 files changed, 4 insertions, 24 deletions
diff --git a/dev-python/guessit/guessit-3.0.0.ebuild b/dev-python/guessit/guessit-3.0.0.ebuild
index a8d2b6d0ebee..aad2290ec2da 100644
--- a/dev-python/guessit/guessit-3.0.0.ebuild
+++ b/dev-python/guessit/guessit-3.0.0.ebuild
@@ -14,8 +14,6 @@ SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
LICENSE="LGPL-3"
SLOT="0"
KEYWORDS="amd64 x86"
-IUSE="test"
-RESTRICT="!test? ( test )"
RDEPEND="
>=dev-python/babelfish-0.5.5[${PYTHON_USEDEP}]
@@ -25,12 +23,8 @@ RDEPEND="
dev-python/setuptools[${PYTHON_USEDEP}]
dev-python/six[${PYTHON_USEDEP}]
"
-DEPEND="${RDEPEND}
- test? (
- >=dev-python/pytest-3.4[${PYTHON_USEDEP}]
- dev-python/pytest-runner[${PYTHON_USEDEP}]
- )
-"
+
+distutils_enable_tests pytest
python_prepare_all() {
# Disable benchmarks as they require unavailable pytest-benchmark.
@@ -42,7 +36,3 @@ python_prepare_all() {
distutils-r1_python_prepare_all
}
-
-python_test() {
- esetup.py test
-}
diff --git a/dev-python/guessit/guessit-9999.ebuild b/dev-python/guessit/guessit-9999.ebuild
index 81cc05628768..a9cdfbda3f14 100644
--- a/dev-python/guessit/guessit-9999.ebuild
+++ b/dev-python/guessit/guessit-9999.ebuild
@@ -15,8 +15,6 @@ EGIT_BRANCH="develop"
LICENSE="LGPL-3"
SLOT="0"
KEYWORDS=""
-IUSE="test"
-RESTRICT="!test? ( test )"
RDEPEND="
>=dev-python/babelfish-0.5.5[${PYTHON_USEDEP}]
@@ -26,12 +24,8 @@ RDEPEND="
dev-python/setuptools[${PYTHON_USEDEP}]
dev-python/six[${PYTHON_USEDEP}]
"
-DEPEND="${RDEPEND}
- test? (
- >=dev-python/pytest-3.4[${PYTHON_USEDEP}]
- dev-python/pytest-runner[${PYTHON_USEDEP}]
- )
-"
+
+distutils_enable_tests pytest
python_prepare_all() {
# Disable benchmarks as they require unavailable pytest-benchmark.
@@ -43,7 +37,3 @@ python_prepare_all() {
distutils-r1_python_prepare_all
}
-
-python_test() {
- esetup.py test
-}