summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/guessit/guessit-9999.ebuild')
-rw-r--r--dev-python/guessit/guessit-9999.ebuild14
1 files changed, 2 insertions, 12 deletions
diff --git a/dev-python/guessit/guessit-9999.ebuild b/dev-python/guessit/guessit-9999.ebuild
index 81cc05628768..a9cdfbda3f14 100644
--- a/dev-python/guessit/guessit-9999.ebuild
+++ b/dev-python/guessit/guessit-9999.ebuild
@@ -15,8 +15,6 @@ EGIT_BRANCH="develop"
LICENSE="LGPL-3"
SLOT="0"
KEYWORDS=""
-IUSE="test"
-RESTRICT="!test? ( test )"
RDEPEND="
>=dev-python/babelfish-0.5.5[${PYTHON_USEDEP}]
@@ -26,12 +24,8 @@ RDEPEND="
dev-python/setuptools[${PYTHON_USEDEP}]
dev-python/six[${PYTHON_USEDEP}]
"
-DEPEND="${RDEPEND}
- test? (
- >=dev-python/pytest-3.4[${PYTHON_USEDEP}]
- dev-python/pytest-runner[${PYTHON_USEDEP}]
- )
-"
+
+distutils_enable_tests pytest
python_prepare_all() {
# Disable benchmarks as they require unavailable pytest-benchmark.
@@ -43,7 +37,3 @@ python_prepare_all() {
distutils-r1_python_prepare_all
}
-
-python_test() {
- esetup.py test
-}