summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--dev-libs/capnproto/Manifest1
-rw-r--r--dev-libs/capnproto/capnproto-0.5.3.1.ebuild36
2 files changed, 37 insertions, 0 deletions
diff --git a/dev-libs/capnproto/Manifest b/dev-libs/capnproto/Manifest
index 1090e831b00f..bce1975f9919 100644
--- a/dev-libs/capnproto/Manifest
+++ b/dev-libs/capnproto/Manifest
@@ -1 +1,2 @@
+DIST capnproto-0.5.3.1.tar.gz 992237 SHA256 e9af9ccfcb6d61be2dca1daf75e90daea32cf6f4c7c24a19919815ce527d9ac8 SHA512 9d359d9ec2a8557ec92919becbd59f9df89633c9b4c7e078f390d02e6b9a4e5f48a1fb3cad595577b3ab7c5effc44733b0b7687002229a9b81b4495fb11c91c8 WHIRLPOOL 4474fd673b02b37f51db973f90ca56451cf8f4c1ccea87c47ed73135d13b495b4c4a6c4267c867c3bb17327585dd49f3e590f6f20536521941ee970f4da755f1
DIST capnproto-0.5.3.tar.gz 992100 SHA256 13c66dc1ce2a038562cddeaf48f71f0bb0e15a1d1a1775efa80dff3cdebeea6c SHA512 c861d8573f9b37bdce3800cc5f875d972017f01176343a118d3fde70d9d19ad3e0af759ef81f2ab1296515a5ef53ce3aa8f8359843ec1a579d9b48d1603a7d16 WHIRLPOOL fb9530092bf37047c76e6b44dcd8457207a7c1e0a41c86e4e8b79ba66edf9cd4641de78ee17d0f38e1b7213543fcc96be0639aa2dd72c7e7cf61d6e0b022a529
diff --git a/dev-libs/capnproto/capnproto-0.5.3.1.ebuild b/dev-libs/capnproto/capnproto-0.5.3.1.ebuild
new file mode 100644
index 000000000000..9905ac655486
--- /dev/null
+++ b/dev-libs/capnproto/capnproto-0.5.3.1.ebuild
@@ -0,0 +1,36 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+
+inherit autotools
+
+DESCRIPTION="RPC/Serialization system with capabilities support"
+HOMEPAGE="http://capnproto.org"
+SRC_URI="https://github.com/sandstorm-io/capnproto/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~arm"
+IUSE="static-libs test"
+
+RDEPEND=""
+DEPEND="test? ( dev-cpp/gtest )"
+
+S=${WORKDIR}/${P}/c++
+
+src_prepare() {
+ sed -e 's/ldconfig/true/' -i Makefile.am || die
+ sed -e 's#gtest/lib/libgtest.la gtest/lib/libgtest_main.la#-lgtest -lgtest_main#' -i Makefile.am || die
+ eautoreconf
+}
+
+src_configure() {
+ econf \
+ $(use_enable static-libs static)
+}
+
+src_install() {
+ default
+ find "${ED}" -name '*.la' -delete
+}