summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-libs/capnproto/capnproto-0.5.3.1.ebuild')
-rw-r--r--dev-libs/capnproto/capnproto-0.5.3.1.ebuild36
1 files changed, 36 insertions, 0 deletions
diff --git a/dev-libs/capnproto/capnproto-0.5.3.1.ebuild b/dev-libs/capnproto/capnproto-0.5.3.1.ebuild
new file mode 100644
index 000000000000..9905ac655486
--- /dev/null
+++ b/dev-libs/capnproto/capnproto-0.5.3.1.ebuild
@@ -0,0 +1,36 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+
+inherit autotools
+
+DESCRIPTION="RPC/Serialization system with capabilities support"
+HOMEPAGE="http://capnproto.org"
+SRC_URI="https://github.com/sandstorm-io/capnproto/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~arm"
+IUSE="static-libs test"
+
+RDEPEND=""
+DEPEND="test? ( dev-cpp/gtest )"
+
+S=${WORKDIR}/${P}/c++
+
+src_prepare() {
+ sed -e 's/ldconfig/true/' -i Makefile.am || die
+ sed -e 's#gtest/lib/libgtest.la gtest/lib/libgtest_main.la#-lgtest -lgtest_main#' -i Makefile.am || die
+ eautoreconf
+}
+
+src_configure() {
+ econf \
+ $(use_enable static-libs static)
+}
+
+src_install() {
+ default
+ find "${ED}" -name '*.la' -delete
+}