summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'app-accessibility')
-rw-r--r--app-accessibility/speechd-el/Manifest1
-rw-r--r--app-accessibility/speechd-el/files/50speechd-el-gentoo.el5
-rw-r--r--app-accessibility/speechd-el/speechd-el-2.11.ebuild45
3 files changed, 51 insertions, 0 deletions
diff --git a/app-accessibility/speechd-el/Manifest b/app-accessibility/speechd-el/Manifest
index 0c8e13f5a768..13621cecb66c 100644
--- a/app-accessibility/speechd-el/Manifest
+++ b/app-accessibility/speechd-el/Manifest
@@ -1 +1,2 @@
+DIST speechd-el-2.11.tar.gz 144000 BLAKE2B ab87885b9b0873a4f00f8a960d9a4c10321a88e1edd402bc92a45dd2fc631be2a17398d0995c4c9e8c88221727739c27b506cab9cafb3a9635193bd5b9b83a3a SHA512 fc6be9f9c6dbf34be559be3ceb38ecca0e94ed7230a8e738f3bdad4153e7443cdf72f34a229c6cb119cab627bc4cfcee0542817715d980e01ed2c776c23b1b6e
DIST speechd-el-2.8.tar.gz 474614 BLAKE2B 36ac862c2f14b3f9b5be25bf666c466093f8e5bf3d456058d73a4eef0cc766d9b36ce990d8a3ee8161edb4190637a199853ac77eaedc28afd101ebd95842c47f SHA512 1a34e433d5ae61c83dfb7d3a9f26e25210613355f3a71e7601f15865cd9693db81dd9f559aef41bd3142d25702db88006bb9fd2053b597799f1b68c48911a3d2
diff --git a/app-accessibility/speechd-el/files/50speechd-el-gentoo.el b/app-accessibility/speechd-el/files/50speechd-el-gentoo.el
new file mode 100644
index 000000000000..d2614768a3cb
--- /dev/null
+++ b/app-accessibility/speechd-el/files/50speechd-el-gentoo.el
@@ -0,0 +1,5 @@
+(add-to-list 'load-path "@SITELISP@")
+(autoload 'speechd-speak "speechd-speak"
+ "Start or restart speaking." t)
+(autoload 'speechd-speak-mode "speechd-speak"
+ "Toggle speaking, the speechd-speak mode." t)
diff --git a/app-accessibility/speechd-el/speechd-el-2.11.ebuild b/app-accessibility/speechd-el/speechd-el-2.11.ebuild
new file mode 100644
index 000000000000..b61e7e11bada
--- /dev/null
+++ b/app-accessibility/speechd-el/speechd-el-2.11.ebuild
@@ -0,0 +1,45 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit optfeature readme.gentoo-r1 elisp
+
+DESCRIPTION="Emacs speech support"
+HOMEPAGE="https://www.freebsoft.org/speechd-el
+ https://github.com/brailcom/speechd-el"
+SRC_URI="https://github.com/brailcom/${PN}/archive/${P}.tar.gz"
+S="${WORKDIR}"/${PN}-${P}
+
+LICENSE="GPL-3+"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86"
+
+RDEPEND=">=app-accessibility/speech-dispatcher-0.7"
+
+DOC_CONTENTS="To get Emacs to speak execute:
+M-x speechd-speak RET
+
+or add following to your initialization file (~/.emacs):
+(speechd-speak)"
+DISABLE_AUTOFORMATTING=YES
+
+SITEFILE="50${PN}-gentoo.el"
+
+src_compile() {
+ emake
+}
+
+src_install() {
+ elisp_src_install
+
+ dobin speechd-log-extractor
+ dodoc ANNOUNCE NEWS README speechd-speak.pdf
+ doinfo ${PN}.info
+}
+
+pkg_postinst() {
+ elisp_pkg_postinst
+
+ optfeature "braille support" "app-accessibility/brltty"
+}