summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'app-doc/gimp-help/gimp-help-2.10.34.ebuild')
-rw-r--r--app-doc/gimp-help/gimp-help-2.10.34.ebuild40
1 files changed, 40 insertions, 0 deletions
diff --git a/app-doc/gimp-help/gimp-help-2.10.34.ebuild b/app-doc/gimp-help/gimp-help-2.10.34.ebuild
new file mode 100644
index 000000000000..4a9d96672c88
--- /dev/null
+++ b/app-doc/gimp-help/gimp-help-2.10.34.ebuild
@@ -0,0 +1,40 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PYTHON_COMPAT=( python3_{9..11} )
+inherit python-any-r1
+
+DESCRIPTION="GNU Image Manipulation Program help files"
+HOMEPAGE="https://docs.gimp.org/"
+SRC_URI="mirror://gimp/help/${P}.tar.bz2"
+
+LICENSE="FDL-1.2"
+SLOT="2"
+KEYWORDS="~alpha ~amd64 ~hppa ~ia64 ~ppc ~ppc64 ~riscv ~sparc ~x86"
+IUSE=""
+
+BDEPEND="
+ ${PYTHON_DEPS}
+ $(python_gen_any_dep 'dev-libs/libxml2[python,${PYTHON_USEDEP}]')
+ app-text/docbook-xml-dtd
+ dev-lang/perl
+ dev-libs/libxslt
+ sys-devel/gettext
+"
+
+python_check_deps() {
+ python_has_version "dev-libs/libxml2[python,${PYTHON_USEDEP}]"
+}
+
+src_configure() {
+ econf --without-gimp
+}
+
+src_compile() {
+ # See bug: 833566
+ python_export_utf8_locale
+ # Affected with bugs: 677198, 876205. Set "emake -j1"
+ emake -j1
+}