summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'app-doc')
-rw-r--r--app-doc/gimp-help/Manifest1
-rw-r--r--app-doc/gimp-help/gimp-help-2.10.34.ebuild40
2 files changed, 41 insertions, 0 deletions
diff --git a/app-doc/gimp-help/Manifest b/app-doc/gimp-help/Manifest
index 037747728007..b47b3228533e 100644
--- a/app-doc/gimp-help/Manifest
+++ b/app-doc/gimp-help/Manifest
@@ -1 +1,2 @@
DIST gimp-help-2.10.0.tar.bz2 187092180 BLAKE2B 29a7fbe3fcb6f3210aeda4bc514d7e0eeca05f9fabd3b9022c7ed1e5a9432876cc3bf530632648e2eb50509add4e387106d9705a1c17469e33496daec737d21b SHA512 2f6d5e7cf0c3b4960c92074ef02d51a1d089c148f6453a66e453a3084cdede280f72c6b77d35f66777adbda8aa273ec2a472fb538142e51bb263c3077eec473a
+DIST gimp-help-2.10.34.tar.bz2 165540436 BLAKE2B eff5afe87bbddf9166647424ef63399a4ebc4215980dddf42f949e18245c60d1095269592f5a314683f7e1d7b27e2b9130215bda5987e7c8dfcafb5cebb6abbc SHA512 316d558f66c96a0d2d0f17baf700020b76aa221f9e220ddfc3e85b10c82b20b9c1cf36893776a342e90af5170e0102eb743b79663451581444d4f881256cf377
diff --git a/app-doc/gimp-help/gimp-help-2.10.34.ebuild b/app-doc/gimp-help/gimp-help-2.10.34.ebuild
new file mode 100644
index 000000000000..4a9d96672c88
--- /dev/null
+++ b/app-doc/gimp-help/gimp-help-2.10.34.ebuild
@@ -0,0 +1,40 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PYTHON_COMPAT=( python3_{9..11} )
+inherit python-any-r1
+
+DESCRIPTION="GNU Image Manipulation Program help files"
+HOMEPAGE="https://docs.gimp.org/"
+SRC_URI="mirror://gimp/help/${P}.tar.bz2"
+
+LICENSE="FDL-1.2"
+SLOT="2"
+KEYWORDS="~alpha ~amd64 ~hppa ~ia64 ~ppc ~ppc64 ~riscv ~sparc ~x86"
+IUSE=""
+
+BDEPEND="
+ ${PYTHON_DEPS}
+ $(python_gen_any_dep 'dev-libs/libxml2[python,${PYTHON_USEDEP}]')
+ app-text/docbook-xml-dtd
+ dev-lang/perl
+ dev-libs/libxslt
+ sys-devel/gettext
+"
+
+python_check_deps() {
+ python_has_version "dev-libs/libxml2[python,${PYTHON_USEDEP}]"
+}
+
+src_configure() {
+ econf --without-gimp
+}
+
+src_compile() {
+ # See bug: 833566
+ python_export_utf8_locale
+ # Affected with bugs: 677198, 876205. Set "emake -j1"
+ emake -j1
+}