summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'app-i18n/ibus-hangul')
-rw-r--r--app-i18n/ibus-hangul/Manifest3
-rw-r--r--app-i18n/ibus-hangul/ibus-hangul-1.4.0.ebuild54
-rw-r--r--app-i18n/ibus-hangul/ibus-hangul-1.4.1.ebuild55
-rw-r--r--app-i18n/ibus-hangul/ibus-hangul-1.4.2-r1.ebuild44
-rw-r--r--app-i18n/ibus-hangul/ibus-hangul-1.4.2.ebuild55
-rw-r--r--app-i18n/ibus-hangul/metadata.xml9
6 files changed, 220 insertions, 0 deletions
diff --git a/app-i18n/ibus-hangul/Manifest b/app-i18n/ibus-hangul/Manifest
new file mode 100644
index 000000000000..f044b679a005
--- /dev/null
+++ b/app-i18n/ibus-hangul/Manifest
@@ -0,0 +1,3 @@
+DIST ibus-hangul-1.4.0.tar.gz 439462 SHA256 a955ec0c9ea90ecd8e8d0fd2de1596a5ba1186463862c387d74a418d1707ca0a SHA512 a2ed7c5ec344d31a37fa3decc502d0b2d724f08c668e6072eade7aa5bdbaba0b5812daf5fb5503e6477d0b289f248894eb81f70729e2a87a40516b1d4d09a6de WHIRLPOOL 06c2eeb6d975c414cd3209500ef562e834c02e7e1c96915cc977a9ff9d8779128e978d52cc8f11940d6a9c23ef34f285d2be63b978f2fe6c3aaf253349e8b949
+DIST ibus-hangul-1.4.1.tar.gz 484065 SHA256 8b7cbc124850df9fb78cdcb38b138f10c648b5519d36a92107616606678b662d SHA512 80d893c33e06108e1477bab067d24e333c9fbfaa3f1a839d9070f2b78694ff80965d9dd23cded3a512f1ed71b60ea5e8390ef9f87d2b63858b09158f90d74b9f WHIRLPOOL 0ec6a6d357e2b6234ddd448c72fa04668381b4de0e82d892e83378f3f1d40a31f5a28c667b68045555cdc74ed441640acc81c91d051683f664ea754021ea526c
+DIST ibus-hangul-1.4.2.tar.gz 483967 SHA256 de79dff94028673f1a00b24f9af35f37f59c12b1737d171a24ac4d34fad20b89 SHA512 ba046d3d234db71043e5dd2fbc8d38443dff4d422e360a09b05dd4c411705967495195b71f8feb5986683c20984217934e3bfe45547b4e43b83aa3f33756963f WHIRLPOOL 046a9b67f6730ffbecd9be13b734fbfc87614dd0e4a72b4e5f866bc6149719e7f5a8b9300faad48470ba20432d3baebd5d7bb173e04885802686237f6c421805
diff --git a/app-i18n/ibus-hangul/ibus-hangul-1.4.0.ebuild b/app-i18n/ibus-hangul/ibus-hangul-1.4.0.ebuild
new file mode 100644
index 000000000000..f37b95fc76a4
--- /dev/null
+++ b/app-i18n/ibus-hangul/ibus-hangul-1.4.0.ebuild
@@ -0,0 +1,54 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=4
+
+PYTHON_DEPEND="2:2.5"
+
+inherit python
+
+DESCRIPTION="The Hangul engine for IBus input platform"
+HOMEPAGE="http://code.google.com/p/ibus/"
+SRC_URI="http://ibus.googlecode.com/files/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="amd64 x86"
+IUSE="nls"
+
+RDEPEND=">=app-i18n/ibus-1.4
+ =dev-python/pygobject-2*
+ =dev-python/pygtk-2*
+ >=app-i18n/libhangul-0.1
+ nls? ( virtual/libintl )"
+DEPEND="${RDEPEND}
+ virtual/pkgconfig
+ nls? (
+ dev-util/intltool
+ >=sys-devel/gettext-0.17
+ )"
+
+DOCS="AUTHORS ChangeLog NEWS README"
+
+pkg_setup() {
+ python_set_active_version 2
+ python_pkg_setup
+}
+
+src_prepare() {
+ >py-compile
+ python_convert_shebangs 2 setup/ibus-setup-hangul.in
+}
+
+src_configure() {
+ econf $(use_enable nls)
+}
+
+pkg_postinst() {
+ python_mod_optimize /usr/share/${PN}
+}
+
+pkg_postrm() {
+ python_mod_cleanup /usr/share/${PN}
+}
diff --git a/app-i18n/ibus-hangul/ibus-hangul-1.4.1.ebuild b/app-i18n/ibus-hangul/ibus-hangul-1.4.1.ebuild
new file mode 100644
index 000000000000..a2f8585fe061
--- /dev/null
+++ b/app-i18n/ibus-hangul/ibus-hangul-1.4.1.ebuild
@@ -0,0 +1,55 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=4
+
+PYTHON_DEPEND="2:2.5"
+
+inherit python
+
+DESCRIPTION="The Hangul engine for IBus input platform"
+HOMEPAGE="http://code.google.com/p/ibus/"
+SRC_URI="http://ibus.googlecode.com/files/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="nls"
+
+RDEPEND=">=app-i18n/ibus-1.4
+ =dev-python/pygobject-2*
+ =dev-python/pygtk-2*
+ >=app-i18n/libhangul-0.1
+ nls? ( virtual/libintl )"
+DEPEND="${RDEPEND}
+ virtual/pkgconfig
+ nls? (
+ dev-util/intltool
+ >=sys-devel/gettext-0.17
+ )"
+
+DOCS="AUTHORS ChangeLog NEWS README"
+
+pkg_setup() {
+ python_set_active_version 2
+ python_pkg_setup
+}
+
+src_prepare() {
+ python_clean_py-compile_files
+ sed -ie "s:python:${EPYTHON}:" \
+ setup/ibus-setup-hangul.in || die
+}
+
+src_configure() {
+ econf $(use_enable nls)
+}
+
+pkg_postinst() {
+ python_mod_optimize /usr/share/${PN}
+}
+
+pkg_postrm() {
+ python_mod_cleanup /usr/share/${PN}
+}
diff --git a/app-i18n/ibus-hangul/ibus-hangul-1.4.2-r1.ebuild b/app-i18n/ibus-hangul/ibus-hangul-1.4.2-r1.ebuild
new file mode 100644
index 000000000000..4e1d96e45717
--- /dev/null
+++ b/app-i18n/ibus-hangul/ibus-hangul-1.4.2-r1.ebuild
@@ -0,0 +1,44 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+PYTHON_COMPAT=( python2_7 )
+
+inherit python-single-r1
+
+DESCRIPTION="The Hangul engine for IBus input platform"
+HOMEPAGE="http://code.google.com/p/ibus/"
+SRC_URI="http://ibus.googlecode.com/files/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="nls"
+
+RDEPEND=">=app-i18n/ibus-1.4[python,${PYTHON_USEDEP}]
+ =dev-python/pygobject-2*[${PYTHON_USEDEP}]
+ =dev-python/pygtk-2*[${PYTHON_USEDEP}]
+ >=app-i18n/libhangul-0.1
+ nls? ( virtual/libintl )
+ ${PYTHON_DEPS}"
+DEPEND="${RDEPEND}
+ virtual/pkgconfig
+ nls? (
+ dev-util/intltool
+ >=sys-devel/gettext-0.17
+ )"
+
+REQUIRED_USE=${PYTHON_REQUIRED_USE}
+
+DOCS="AUTHORS ChangeLog NEWS README"
+
+src_prepare() {
+ sed -ie "s:python:${EPYTHON}:" \
+ setup/ibus-setup-hangul.in || die
+}
+
+src_configure() {
+ econf $(use_enable nls)
+}
diff --git a/app-i18n/ibus-hangul/ibus-hangul-1.4.2.ebuild b/app-i18n/ibus-hangul/ibus-hangul-1.4.2.ebuild
new file mode 100644
index 000000000000..895eb370f129
--- /dev/null
+++ b/app-i18n/ibus-hangul/ibus-hangul-1.4.2.ebuild
@@ -0,0 +1,55 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+PYTHON_DEPEND="2:2.5"
+
+inherit python
+
+DESCRIPTION="The Hangul engine for IBus input platform"
+HOMEPAGE="http://code.google.com/p/ibus/"
+SRC_URI="http://ibus.googlecode.com/files/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="amd64 x86"
+IUSE="nls"
+
+RDEPEND=">=app-i18n/ibus-1.4
+ =dev-python/pygobject-2*
+ =dev-python/pygtk-2*
+ >=app-i18n/libhangul-0.1
+ nls? ( virtual/libintl )"
+DEPEND="${RDEPEND}
+ virtual/pkgconfig
+ nls? (
+ dev-util/intltool
+ >=sys-devel/gettext-0.17
+ )"
+
+DOCS="AUTHORS ChangeLog NEWS README"
+
+pkg_setup() {
+ python_set_active_version 2
+ python_pkg_setup
+}
+
+src_prepare() {
+ python_clean_py-compile_files
+ sed -ie "s:python:${EPYTHON}:" \
+ setup/ibus-setup-hangul.in || die
+}
+
+src_configure() {
+ econf $(use_enable nls)
+}
+
+pkg_postinst() {
+ python_mod_optimize /usr/share/${PN}
+}
+
+pkg_postrm() {
+ python_mod_cleanup /usr/share/${PN}
+}
diff --git a/app-i18n/ibus-hangul/metadata.xml b/app-i18n/ibus-hangul/metadata.xml
new file mode 100644
index 000000000000..299a127ff9b1
--- /dev/null
+++ b/app-i18n/ibus-hangul/metadata.xml
@@ -0,0 +1,9 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>cjk</herd>
+ <longdescription lang="en">The Hangul engine for IBus platform. It provides Korean input method from libhangul.</longdescription>
+ <upstream>
+ <remote-id type="google-code">ibus</remote-id>
+ </upstream>
+</pkgmetadata>