summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorfulgurance <zohran.londais@gmail.com>2019-05-03 17:10:59 +0200
committerJoonas Niilola <juippis@gentoo.org>2019-08-20 15:41:31 +0300
commit1f3c291a1d794868c714acf741974563d9ff8791 (patch)
treecdd6a59397ae9c8f5187b404c72b88f2f4e95814 /app-laptop/msi-keyboard/msi-keyboard-1.0.ebuild
parentdev-dotnet/libgdiplus: bump version to 6.0.2 (diff)
downloadgentoo-1f3c291a1d794868c714acf741974563d9ff8791.tar.gz
gentoo-1f3c291a1d794868c714acf741974563d9ff8791.tar.bz2
gentoo-1f3c291a1d794868c714acf741974563d9ff8791.zip
app-laptop/msi-keyboard: New package
Control backlight of MSI laptop keyboards Package-Manager: Portage 2.3.72, Repoman 2.3.17 Signed-off-by: Zohran Londais <zohran.londais@gmail.com> Closes: https://github.com/gentoo/gentoo/pull/11884 Closes: https://github.com/gentoo/gentoo/pull/10476 Signed-off-by: Joonas Niilola <juippis@gentoo.org>
Diffstat (limited to 'app-laptop/msi-keyboard/msi-keyboard-1.0.ebuild')
-rw-r--r--app-laptop/msi-keyboard/msi-keyboard-1.0.ebuild26
1 files changed, 26 insertions, 0 deletions
diff --git a/app-laptop/msi-keyboard/msi-keyboard-1.0.ebuild b/app-laptop/msi-keyboard/msi-keyboard-1.0.ebuild
new file mode 100644
index 000000000000..7e074cc86a8a
--- /dev/null
+++ b/app-laptop/msi-keyboard/msi-keyboard-1.0.ebuild
@@ -0,0 +1,26 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit udev
+
+DESCRIPTION="Control backlight of MSI laptop keyboards"
+HOMEPAGE="https://github.com/makkarpov/msi-keyboard"
+SRC_URI="https://github.com/makkarpov/msi-keyboard/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64"
+
+RDEPEND="dev-libs/hidapi"
+
+PATCHES=(
+ "${FILESDIR}"/${P}-makefile.patch
+)
+
+src_install() {
+ udev_dorules 99-msi-keyboard.rules
+ udev_reload
+ dobin msi-keyboard
+}