summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-cpp')
-rw-r--r--dev-cpp/rapidfuzz-cpp/Manifest3
-rw-r--r--dev-cpp/rapidfuzz-cpp/rapidfuzz-cpp-2.0.0.ebuild32
-rw-r--r--dev-cpp/rapidfuzz-cpp/rapidfuzz-cpp-2.2.0.ebuild32
-rw-r--r--dev-cpp/rapidfuzz-cpp/rapidfuzz-cpp-2.2.2.ebuild32
4 files changed, 0 insertions, 99 deletions
diff --git a/dev-cpp/rapidfuzz-cpp/Manifest b/dev-cpp/rapidfuzz-cpp/Manifest
index 6e38a3abbed8..f7816d3b8aea 100644
--- a/dev-cpp/rapidfuzz-cpp/Manifest
+++ b/dev-cpp/rapidfuzz-cpp/Manifest
@@ -1,5 +1,2 @@
-DIST rapidfuzz-cpp-2.0.0.gh.tar.gz 287804 BLAKE2B f49e5681c41da985c71b61f7deb3f50ec778c15c9ccbc0484107b7508adf22c24b707c7f6a309ff307312e3e862ff7b8e0672c528201708a4ed5f3361dd76935 SHA512 02af141b123545303d634ffe84fbe83e635f06c9ffa3a6506661e53beb22fe7221942b3e46d33b2a49ef929c5de9acfb00c48cb5685c760506c5fcf37c716f9a
DIST rapidfuzz-cpp-2.1.1.gh.tar.gz 294473 BLAKE2B 71dc85cc8b5b11224ee26b3be117869e26c4fe43a780baa5629282675c2a9ca523deb22fbe58c15f265b53960fa0a8310b99ecd2fc412b2dbaacd3983dd69ab9 SHA512 802f465a1e3e21e6417c40e77e241a4e50a996f6aa70739f25cee228490fff4f2b366d6029beea9639769493f63520e5242665a91a6f105ebf1feb377a3a2e50
-DIST rapidfuzz-cpp-2.2.0.gh.tar.gz 297682 BLAKE2B 98b781eb64e14ed62ab388e6858f1183e231aa293d5561f778a786fe7a6cca97ead9af9665ec29c6683acbbc3513df15832879e6fff3ab383e52c41d1a126579 SHA512 a3dee89e37d085b2c41ab6541a5e7098ab1dcc42255ee722faa8d723a1d61f4593036a2a8c875f71e426d8964b3fc4fda955432df00108c713c0d6028688a2f1
-DIST rapidfuzz-cpp-2.2.2.gh.tar.gz 299202 BLAKE2B fcdb0cfd464814b7dfefcb9f6d35381063e610d0b08451b3e840398c791a1d6043eaba81fe6a63be32c653f045dea9bebcaa655e2db5e4b0a27cced7086b9665 SHA512 81811f8e9fb1fa022ea358dc5d8cd09314eb074a91befce8573b3dfce1415e6c0f41154a13fbc43343a9f8ef6ee138efe75394ad9e90b72c90c54aa620747084
DIST rapidfuzz-cpp-2.2.3.gh.tar.gz 299404 BLAKE2B e45cf997cb6454aae781cb67663bcc12a0b507efd88b9293a4ec3424fb67ff713983e77041808488abad3d710a5a81aa45295f838908a8fdbad1f980a8eeb00f SHA512 5ef4833334ccc3309d43ae4a2644eb57fa2a382b797c791b150b8d78451d7e6d57a8af23d0b7645eecfe539a128d2d8585e2a7380b6772b23cf8fd71d6a7f38b
diff --git a/dev-cpp/rapidfuzz-cpp/rapidfuzz-cpp-2.0.0.ebuild b/dev-cpp/rapidfuzz-cpp/rapidfuzz-cpp-2.0.0.ebuild
deleted file mode 100644
index d2237c7d8073..000000000000
--- a/dev-cpp/rapidfuzz-cpp/rapidfuzz-cpp-2.0.0.ebuild
+++ /dev/null
@@ -1,32 +0,0 @@
-# Copyright 2022-2023 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=8
-
-inherit cmake
-
-DESCRIPTION="Rapid fuzzy string matching in C++"
-HOMEPAGE="https://github.com/maxbachmann/rapidfuzz-cpp/"
-SRC_URI="
- https://github.com/maxbachmann/rapidfuzz-cpp/archive/v${PV}.tar.gz
- -> ${P}.gh.tar.gz
-"
-
-LICENSE="MIT"
-SLOT="0"
-KEYWORDS="~alpha amd64 arm arm64 ~hppa ~ia64 ~loong ~mips ppc ppc64 ~riscv ~s390 sparc x86"
-IUSE="test"
-RESTRICT="!test? ( test )"
-
-BDEPEND="
- test? (
- >=dev-cpp/catch-3
- )
-"
-
-src_configure() {
- local mycmakeargs=(
- -DRAPIDFUZZ_BUILD_TESTING=$(usex test)
- )
- cmake_src_configure
-}
diff --git a/dev-cpp/rapidfuzz-cpp/rapidfuzz-cpp-2.2.0.ebuild b/dev-cpp/rapidfuzz-cpp/rapidfuzz-cpp-2.2.0.ebuild
deleted file mode 100644
index 1cf4910aa2c4..000000000000
--- a/dev-cpp/rapidfuzz-cpp/rapidfuzz-cpp-2.2.0.ebuild
+++ /dev/null
@@ -1,32 +0,0 @@
-# Copyright 2022-2023 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=8
-
-inherit cmake
-
-DESCRIPTION="Rapid fuzzy string matching in C++"
-HOMEPAGE="https://github.com/maxbachmann/rapidfuzz-cpp/"
-SRC_URI="
- https://github.com/maxbachmann/rapidfuzz-cpp/archive/v${PV}.tar.gz
- -> ${P}.gh.tar.gz
-"
-
-LICENSE="MIT"
-SLOT="0"
-KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~loong ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86"
-IUSE="test"
-RESTRICT="!test? ( test )"
-
-BDEPEND="
- test? (
- >=dev-cpp/catch-3
- )
-"
-
-src_configure() {
- local mycmakeargs=(
- -DRAPIDFUZZ_BUILD_TESTING=$(usex test)
- )
- cmake_src_configure
-}
diff --git a/dev-cpp/rapidfuzz-cpp/rapidfuzz-cpp-2.2.2.ebuild b/dev-cpp/rapidfuzz-cpp/rapidfuzz-cpp-2.2.2.ebuild
deleted file mode 100644
index 1cf4910aa2c4..000000000000
--- a/dev-cpp/rapidfuzz-cpp/rapidfuzz-cpp-2.2.2.ebuild
+++ /dev/null
@@ -1,32 +0,0 @@
-# Copyright 2022-2023 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=8
-
-inherit cmake
-
-DESCRIPTION="Rapid fuzzy string matching in C++"
-HOMEPAGE="https://github.com/maxbachmann/rapidfuzz-cpp/"
-SRC_URI="
- https://github.com/maxbachmann/rapidfuzz-cpp/archive/v${PV}.tar.gz
- -> ${P}.gh.tar.gz
-"
-
-LICENSE="MIT"
-SLOT="0"
-KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~loong ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86"
-IUSE="test"
-RESTRICT="!test? ( test )"
-
-BDEPEND="
- test? (
- >=dev-cpp/catch-3
- )
-"
-
-src_configure() {
- local mycmakeargs=(
- -DRAPIDFUZZ_BUILD_TESTING=$(usex test)
- )
- cmake_src_configure
-}