summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-haskell/haddock/haddock-2.16.1.ebuild')
-rw-r--r--dev-haskell/haddock/haddock-2.16.1.ebuild69
1 files changed, 0 insertions, 69 deletions
diff --git a/dev-haskell/haddock/haddock-2.16.1.ebuild b/dev-haskell/haddock/haddock-2.16.1.ebuild
deleted file mode 100644
index f914d15c4c06..000000000000
--- a/dev-haskell/haddock/haddock-2.16.1.ebuild
+++ /dev/null
@@ -1,69 +0,0 @@
-# Copyright 1999-2020 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=5
-
-# ebuild generated by hackport 0.4.4.9999
-
-CABAL_FEATURES="bin test-suite"
-CABAL_FEATURES+=" nocabaldep"
-inherit haskell-cabal pax-utils
-
-DESCRIPTION="A documentation-generation tool for Haskell libraries"
-HOMEPAGE="https://www.haskell.org/haddock/"
-SRC_URI="https://hackage.haskell.org/package/${P}/${P}.tar.gz"
-
-LICENSE="BSD"
-SLOT="0"
-KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux"
-IUSE=""
-
-RESTRICT=test # tests are outdated
-
-RDEPEND=""
-DEPEND="${RDEPEND}
- >=dev-haskell/cabal-1.10
- >=dev-lang/ghc-7.4.1
- ~dev-haskell/haddock-api-2.16.1
-"
-
-src_prepare() {
- if [[ ! -e "${S}/html" ]]; then
- ln -s resources/html "${S}/html" || die "Could not create symbolic link ${S}/html"
- fi
-}
-
-src_configure() {
- # create a fake haddock executable. it'll set the right version to cabal
- # configure, but will eventually get overwritten in src_compile by
- # the real executable.
- local exe="${S}/dist/build/haddock/haddock"
- mkdir -p $(dirname "${exe}")
- echo -e "#!/bin/sh\necho Haddock version ${PV}" > "${exe}"
- chmod +x "${exe}"
-
- # we use 'nocabaldep' to use ghc's bundled Cabal
- # as external one is likely to break our haddock
- # (known to work on 1.16.0 and breaks on 1.16.0.1!)
- haskell-cabal_src_configure \
- --flags=-in-ghc-tree \
- --ghc-options=-rtsopts \
- --with-haddock="${exe}" \
- --constraint="Cabal == $(cabal-version)"
-
-}
-
-src_compile() {
- # when building the (recursive..) haddock docs, change the datadir to the
- # current directory, as we're using haddock inplace even if it's built to be
- # installed into the system first.
- haddock_datadir="${S}" haskell-cabal_src_compile
- pax-mark -m "${S}/dist/build/haddock"
-}
-
-src_install() {
- cabal_src_install
- # haddock uses GHC-api to process TH source.
- # TH requires GHCi which needs mmap('rwx') (bug #299709)
- pax-mark -m "${D}/usr/bin/${PN}"
-}