summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-haskell/haddock')
-rw-r--r--dev-haskell/haddock/Manifest4
-rw-r--r--dev-haskell/haddock/haddock-2.14.3.0.7.8.3.ebuild67
-rw-r--r--dev-haskell/haddock/haddock-2.16.1.ebuild69
-rw-r--r--dev-haskell/haddock/haddock-2.17.2.ebuild34
-rw-r--r--dev-haskell/haddock/haddock-2.23.1.ebuild34
-rw-r--r--dev-haskell/haddock/metadata.xml7
6 files changed, 0 insertions, 215 deletions
diff --git a/dev-haskell/haddock/Manifest b/dev-haskell/haddock/Manifest
deleted file mode 100644
index fb245c5e8975..000000000000
--- a/dev-haskell/haddock/Manifest
+++ /dev/null
@@ -1,4 +0,0 @@
-DIST haddock-2.14.3.0.7.8.3.tar.gz 230282 BLAKE2B cb5336c72e0fa3036bf7ceaa202ff35e1d104fcb05c4317f16e78c0517b27529c1fab28e2ee4f2e14cbf2db592ff88a6b01d1840193c9a69233230fec1ffc423 SHA512 62ae4a29c877c3b9742828fcda2f1f045357f41b4a2c495a4791a42d412d41b3d206cdcb73e2d1bd4e95c40371dae865f4eaa37031cda6c1bada5dfed963c2be
-DIST haddock-2.16.1.tar.gz 216323 BLAKE2B feddc77d8072dfafb4b06486f57db89a0136ed53644efb0336a26e6c3f31789cf57e302e7bbfbfb9af036a00cbf801c47398347bd664333f0a35debdf794ada3 SHA512 709af410f8746819c8c067f3549d79ba0ecaa312fb6b19acf670a9a3e4c94e94b8e546493e08293eceeb488bc0891a8ebe033a58411c4af935b445cd7f3014b8
-DIST haddock-2.17.2.tar.gz 245690 BLAKE2B dc6f646a5972add1a5ac0e2a2a4119df5f8f0604984f0fa3f828e72bca96f8ec98b09ce65de6bb94a2714c64680a79ae3dd49f60a27cbf5483cb71f239180c87 SHA512 f8f06abd3b231fae36b900d54a70107dcd6718bab7726ad7bd8392c9053700b96672cf9efa0854033a5c1473dcdf00c390f253bc244ff5f4d25e70dd76c8ea1d
-DIST haddock-2.23.1.tar.gz 302698 BLAKE2B 1dae0019ddc08c537aec2f0fa71f5bd1570db4061d22bf53f05aa0e211c3280d09c6a6481f704c34895e0bf70fd2b5ac95644dab23b05cc2b6fec59c845f86c5 SHA512 e69b3b5f2dcadeccc33696ee8d0646387860b98d86c08d4c07d829e3eabc4159adac0a11d408850ef54face5fa835ab8217d1057b14d8de8d758efbfc7a700db
diff --git a/dev-haskell/haddock/haddock-2.14.3.0.7.8.3.ebuild b/dev-haskell/haddock/haddock-2.14.3.0.7.8.3.ebuild
deleted file mode 100644
index 3e5a6f1536dc..000000000000
--- a/dev-haskell/haddock/haddock-2.14.3.0.7.8.3.ebuild
+++ /dev/null
@@ -1,67 +0,0 @@
-# Copyright 1999-2020 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=5
-
-# ebuild generated by hackport 0.3.6.9999
-
-CABAL_FEATURES="bin lib profile haddock hoogle hscolour test-suite"
-CABAL_FEATURES+=" nocabaldep"
-inherit haskell-cabal pax-utils
-
-DESCRIPTION="A documentation-generation tool for Haskell libraries"
-HOMEPAGE="https://www.haskell.org/haddock/"
-#SRC_URI="https://hackage.haskell.org/package/${P}/${P}.tar.gz"
-SRC_URI="http://code.haskell.org/~slyfox/snapshots/${P}.tar.gz"
-
-LICENSE="BSD"
-SLOT="0/${PV}"
-KEYWORDS="~amd64 ~x86"
-IUSE=""
-
-RESTRICT=test # many test depends are not keyworded yet
-
-RDEPEND="dev-haskell/ghc-paths:=[profile?]
- >=dev-haskell/xhtml-3000.2:=[profile?] <dev-haskell/xhtml-3000.3:=[profile?]
- >=dev-lang/ghc-7.8.3:= <dev-lang/ghc-7.9:=
-"
-DEPEND="${RDEPEND}
-"
-
-src_prepare() {
- if [[ ! -e "${S}/html" ]]; then
- ln -s resources/html "${S}/html" || die "Could not create symbolic link ${S}/html"
- fi
-}
-
-src_configure() {
- # create a fake haddock executable. it'll set the right version to cabal
- # configure, but will eventually get overwritten in src_compile by
- # the real executable.
- local exe="${S}/dist/build/haddock/haddock"
- mkdir -p $(dirname "${exe}")
- echo -e "#!/bin/sh\necho Haddock version ${PV}" > "${exe}"
- chmod +x "${exe}"
-
- # we use 'nocabaldep' to use ghc's bundled Cabal
- # as external one is likely to break our haddock
- # (known to work on 1.16.0 and breaks on 1.16.0.1!)
- haskell-cabal_src_configure \
- --ghc-options=-rtsopts \
- --with-haddock="${exe}" \
- --constraint="Cabal == $(cabal-version)"
-}
-
-src_compile() {
- # when building the (recursive..) haddock docs, change the datadir to the
- # current directory, as we're using haddock inplace even if it's built to be
- # installed into the system first.
- haddock_datadir="${S}" haskell-cabal_src_compile
-}
-
-src_install() {
- cabal_src_install
- # haddock uses GHC-api to process TH source.
- # TH requires GHCi which needs mmap('rwx') (bug #299709)
- pax-mark -m "${D}/usr/bin/${PN}"
-}
diff --git a/dev-haskell/haddock/haddock-2.16.1.ebuild b/dev-haskell/haddock/haddock-2.16.1.ebuild
deleted file mode 100644
index f914d15c4c06..000000000000
--- a/dev-haskell/haddock/haddock-2.16.1.ebuild
+++ /dev/null
@@ -1,69 +0,0 @@
-# Copyright 1999-2020 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=5
-
-# ebuild generated by hackport 0.4.4.9999
-
-CABAL_FEATURES="bin test-suite"
-CABAL_FEATURES+=" nocabaldep"
-inherit haskell-cabal pax-utils
-
-DESCRIPTION="A documentation-generation tool for Haskell libraries"
-HOMEPAGE="https://www.haskell.org/haddock/"
-SRC_URI="https://hackage.haskell.org/package/${P}/${P}.tar.gz"
-
-LICENSE="BSD"
-SLOT="0"
-KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux"
-IUSE=""
-
-RESTRICT=test # tests are outdated
-
-RDEPEND=""
-DEPEND="${RDEPEND}
- >=dev-haskell/cabal-1.10
- >=dev-lang/ghc-7.4.1
- ~dev-haskell/haddock-api-2.16.1
-"
-
-src_prepare() {
- if [[ ! -e "${S}/html" ]]; then
- ln -s resources/html "${S}/html" || die "Could not create symbolic link ${S}/html"
- fi
-}
-
-src_configure() {
- # create a fake haddock executable. it'll set the right version to cabal
- # configure, but will eventually get overwritten in src_compile by
- # the real executable.
- local exe="${S}/dist/build/haddock/haddock"
- mkdir -p $(dirname "${exe}")
- echo -e "#!/bin/sh\necho Haddock version ${PV}" > "${exe}"
- chmod +x "${exe}"
-
- # we use 'nocabaldep' to use ghc's bundled Cabal
- # as external one is likely to break our haddock
- # (known to work on 1.16.0 and breaks on 1.16.0.1!)
- haskell-cabal_src_configure \
- --flags=-in-ghc-tree \
- --ghc-options=-rtsopts \
- --with-haddock="${exe}" \
- --constraint="Cabal == $(cabal-version)"
-
-}
-
-src_compile() {
- # when building the (recursive..) haddock docs, change the datadir to the
- # current directory, as we're using haddock inplace even if it's built to be
- # installed into the system first.
- haddock_datadir="${S}" haskell-cabal_src_compile
- pax-mark -m "${S}/dist/build/haddock"
-}
-
-src_install() {
- cabal_src_install
- # haddock uses GHC-api to process TH source.
- # TH requires GHCi which needs mmap('rwx') (bug #299709)
- pax-mark -m "${D}/usr/bin/${PN}"
-}
diff --git a/dev-haskell/haddock/haddock-2.17.2.ebuild b/dev-haskell/haddock/haddock-2.17.2.ebuild
deleted file mode 100644
index e37d8cb4a761..000000000000
--- a/dev-haskell/haddock/haddock-2.17.2.ebuild
+++ /dev/null
@@ -1,34 +0,0 @@
-# Copyright 1999-2020 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=6
-
-# ebuild generated by hackport 0.5.9999
-#hackport: flags: -in-ghc-tree
-
-CABAL_FEATURES="bin test-suite"
-inherit haskell-cabal
-
-DESCRIPTION="A documentation-generation tool for Haskell libraries"
-HOMEPAGE="https://www.haskell.org/haddock/"
-SRC_URI="https://hackage.haskell.org/package/${P}/${P}.tar.gz"
-
-LICENSE="BSD"
-SLOT="0"
-#keep in sync with ghc-8.0.1
-KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux"
-IUSE=""
-
-RESTRICT=test # there is no haddock-test on hackage yet
-
-RDEPEND=">=dev-haskell/haddock-api-2.17:= <dev-haskell/haddock-api-2.18:=
- >=dev-lang/ghc-7.4.1:=
-"
-DEPEND="${RDEPEND}
- >=dev-haskell/cabal-1.10
-"
-
-src_configure() {
- haskell-cabal_src_configure \
- --flag=-in-ghc-tree
-}
diff --git a/dev-haskell/haddock/haddock-2.23.1.ebuild b/dev-haskell/haddock/haddock-2.23.1.ebuild
deleted file mode 100644
index d2e622f4d065..000000000000
--- a/dev-haskell/haddock/haddock-2.23.1.ebuild
+++ /dev/null
@@ -1,34 +0,0 @@
-# Copyright 1999-2020 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=7
-
-# ebuild generated by hackport 0.6.4.9999
-#hackport: flags: -in-ghc-tree
-
-CABAL_FEATURES="" # test-suite unavailable
-inherit haskell-cabal
-
-DESCRIPTION="A documentation-generation tool for Haskell libraries"
-HOMEPAGE="http://www.haskell.org/haddock/"
-SRC_URI="https://hackage.haskell.org/package/${P}/${P}.tar.gz"
-
-LICENSE="BSD"
-SLOT="0"
-# keep in sync with ghc-8.8.3
-KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux"
-IUSE=""
-
-RESTRICT=test # test suite unavailable
-
-RDEPEND="~dev-haskell/haddock-api-2.23.1:=
- >=dev-lang/ghc-8.8.1:=
-"
-DEPEND="${RDEPEND}
- >=dev-haskell/cabal-3.0.0.0
-" # test? ( ~dev-haskell/haddock-test-0.0.1 )
-
-src_configure() {
- haskell-cabal_src_configure \
- --flag=-in-ghc-tree
-}
diff --git a/dev-haskell/haddock/metadata.xml b/dev-haskell/haddock/metadata.xml
deleted file mode 100644
index 522384de8446..000000000000
--- a/dev-haskell/haddock/metadata.xml
+++ /dev/null
@@ -1,7 +0,0 @@
-<?xml version="1.0" encoding="UTF-8"?>
-<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
-<pkgmetadata>
-<maintainer type="project">
- <email>haskell@gentoo.org</email>
-</maintainer>
-</pkgmetadata>