summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-haskell/monad-loops/monad-loops-0.4.2.1.ebuild')
-rw-r--r--dev-haskell/monad-loops/monad-loops-0.4.2.1.ebuild30
1 files changed, 30 insertions, 0 deletions
diff --git a/dev-haskell/monad-loops/monad-loops-0.4.2.1.ebuild b/dev-haskell/monad-loops/monad-loops-0.4.2.1.ebuild
new file mode 100644
index 000000000000..c38a5e3bc318
--- /dev/null
+++ b/dev-haskell/monad-loops/monad-loops-0.4.2.1.ebuild
@@ -0,0 +1,30 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+# ebuild generated by hackport 0.4.2.9999
+
+CABAL_FEATURES="lib profile haddock hoogle hscolour"
+inherit haskell-cabal
+
+DESCRIPTION="Monadic loops"
+HOMEPAGE="https://github.com/mokus0/monad-loops"
+SRC_URI="mirror://hackage/packages/archive/${PN}/${PV}/${P}.tar.gz"
+
+LICENSE="public-domain"
+SLOT="0/${PV}"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+RDEPEND=">=dev-lang/ghc-7.4.1:=
+"
+DEPEND="${RDEPEND}
+ >=dev-haskell/cabal-1.6
+"
+
+src_configure() {
+ haskell-cabal_src_configure \
+ --flags=base4
+}