summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-haskell/monad-loops')
-rw-r--r--dev-haskell/monad-loops/Manifest3
-rw-r--r--dev-haskell/monad-loops/metadata.xml15
-rw-r--r--dev-haskell/monad-loops/monad-loops-0.4.2.1.ebuild30
-rw-r--r--dev-haskell/monad-loops/monad-loops-0.4.2.ebuild28
-rw-r--r--dev-haskell/monad-loops/monad-loops-0.4.3.ebuild27
5 files changed, 103 insertions, 0 deletions
diff --git a/dev-haskell/monad-loops/Manifest b/dev-haskell/monad-loops/Manifest
new file mode 100644
index 000000000000..fee2d84675ae
--- /dev/null
+++ b/dev-haskell/monad-loops/Manifest
@@ -0,0 +1,3 @@
+DIST monad-loops-0.4.2.1.tar.gz 4515 SHA256 a6e888a462aff46297527e90a7bf0171bc2cff4cab073973bdbf2fc09ae5f9b6 SHA512 f8f8adae8250761da332ea4533796870e41ff8ec9881198a2a921bb31dcb68e319b4f5be077c45408c44f0151ce772093dcd6d80d6cc6fa4aeb6a323a5964972 WHIRLPOOL eb95dbbeca759a160fce3d708feebcb9b177b85bb78db3257897cec2a37ef7cd8502c1ce69f6de4332bc44197d1fcc9d21892c8d6cc4ae1c7f9361652c0d93b4
+DIST monad-loops-0.4.2.tar.gz 4503 SHA256 4837678eea9277fec793e7ea03a28929c0546cdc58d77c7643e7864f2e025f23 SHA512 50d2e83a4cb987532e1f450064d2b5866c523f6410c7fa1d7c9b62e169a788a706d2446386c6d9b7998c62fe3087efa154fc16d52f27ad955698c0a78e6477be WHIRLPOOL 6f5f0d5c854be9a907c10ac1d7343774a6b5116d62c5caa4dcfeb2edc4c154f08b4455e93ff8d40d0b3e4076a70624bd567a5052e9e001e9192be7bbc3780af4
+DIST monad-loops-0.4.3.tar.gz 4996 SHA256 7eaaaf6bc43661e9e86e310ff8c56fbea16eb6bf13c31a2e28103138ac164c18 SHA512 41a1314777661a411acf62dfa25cbb1a59fedd5d60d1a2b8566a3dd64dec361ab1fe35827320529a723a612e0443571ce38b17fa900eb8d5289bc52f653d47a5 WHIRLPOOL 7b3e10c329ad9c7208121a1113c9ec72565f6ed567f28cc60dccb0900d75d7c01ddd08cdd8e37afe56e7216f706b82b07772ff7204c4dbdd4d093ac050dde030
diff --git a/dev-haskell/monad-loops/metadata.xml b/dev-haskell/monad-loops/metadata.xml
new file mode 100644
index 000000000000..1eb0752ea4b6
--- /dev/null
+++ b/dev-haskell/monad-loops/metadata.xml
@@ -0,0 +1,15 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>haskell</herd>
+ <longdescription>
+ Some useful control operators for looping.
+
+ New in 0.3.2.0: various functions for traversing lists and
+ computing minima/maxima using arbitrary procedures to compare
+ or score the elements.
+ </longdescription>
+ <upstream>
+ <remote-id type="github">mokus0/monad-loops</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/dev-haskell/monad-loops/monad-loops-0.4.2.1.ebuild b/dev-haskell/monad-loops/monad-loops-0.4.2.1.ebuild
new file mode 100644
index 000000000000..c38a5e3bc318
--- /dev/null
+++ b/dev-haskell/monad-loops/monad-loops-0.4.2.1.ebuild
@@ -0,0 +1,30 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+# ebuild generated by hackport 0.4.2.9999
+
+CABAL_FEATURES="lib profile haddock hoogle hscolour"
+inherit haskell-cabal
+
+DESCRIPTION="Monadic loops"
+HOMEPAGE="https://github.com/mokus0/monad-loops"
+SRC_URI="mirror://hackage/packages/archive/${PN}/${PV}/${P}.tar.gz"
+
+LICENSE="public-domain"
+SLOT="0/${PV}"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+RDEPEND=">=dev-lang/ghc-7.4.1:=
+"
+DEPEND="${RDEPEND}
+ >=dev-haskell/cabal-1.6
+"
+
+src_configure() {
+ haskell-cabal_src_configure \
+ --flags=base4
+}
diff --git a/dev-haskell/monad-loops/monad-loops-0.4.2.ebuild b/dev-haskell/monad-loops/monad-loops-0.4.2.ebuild
new file mode 100644
index 000000000000..1a0f79d4135c
--- /dev/null
+++ b/dev-haskell/monad-loops/monad-loops-0.4.2.ebuild
@@ -0,0 +1,28 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+# ebuild generated by hackport 0.3.2.9999
+
+CABAL_FEATURES="lib profile haddock hoogle hscolour"
+inherit haskell-cabal
+
+DESCRIPTION="Monadic loops"
+HOMEPAGE="https://github.com/mokus0/monad-loops"
+SRC_URI="mirror://hackage/packages/archive/${PN}/${PV}/${P}.tar.gz"
+
+LICENSE="public-domain"
+SLOT="0/${PV}"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+RDEPEND=">=dev-lang/ghc-6.10.4:="
+DEPEND="${RDEPEND}
+ >=dev-haskell/cabal-1.6"
+
+src_configure() {
+ haskell-cabal_src_configure \
+ --flags=base4
+}
diff --git a/dev-haskell/monad-loops/monad-loops-0.4.3.ebuild b/dev-haskell/monad-loops/monad-loops-0.4.3.ebuild
new file mode 100644
index 000000000000..b3bea6743ff6
--- /dev/null
+++ b/dev-haskell/monad-loops/monad-loops-0.4.3.ebuild
@@ -0,0 +1,27 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+# ebuild generated by hackport 0.4.5.9999
+
+CABAL_FEATURES="lib profile haddock hoogle hscolour test-suite"
+inherit haskell-cabal
+
+DESCRIPTION="Monadic loops"
+HOMEPAGE="https://github.com/mokus0/monad-loops"
+SRC_URI="mirror://hackage/packages/archive/${PN}/${PV}/${P}.tar.gz"
+
+LICENSE="public-domain"
+SLOT="0/${PV}"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+RDEPEND=">=dev-lang/ghc-7.4.1:=
+"
+DEPEND="${RDEPEND}
+ >=dev-haskell/cabal-1.8
+ test? ( dev-haskell/tasty
+ dev-haskell/tasty-hunit )
+"