summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-haskell/tasty-quickcheck/tasty-quickcheck-0.10.2.ebuild')
-rw-r--r--dev-haskell/tasty-quickcheck/tasty-quickcheck-0.10.2.ebuild29
1 files changed, 29 insertions, 0 deletions
diff --git a/dev-haskell/tasty-quickcheck/tasty-quickcheck-0.10.2.ebuild b/dev-haskell/tasty-quickcheck/tasty-quickcheck-0.10.2.ebuild
new file mode 100644
index 000000000000..f9bb7b4d7cf9
--- /dev/null
+++ b/dev-haskell/tasty-quickcheck/tasty-quickcheck-0.10.2.ebuild
@@ -0,0 +1,29 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+# ebuild generated by hackport 0.7.3.0
+
+CABAL_FEATURES="lib profile haddock hoogle hscolour test-suite"
+inherit haskell-cabal
+
+DESCRIPTION="QuickCheck support for the Tasty test framework"
+HOMEPAGE="https://github.com/UnkindPartition/tasty"
+
+LICENSE="MIT"
+SLOT="0/${PV}"
+KEYWORDS="~amd64 ~arm64 ~ppc64 ~riscv ~x86"
+
+RDEPEND="dev-haskell/optparse-applicative:=[profile?]
+ >=dev-haskell/quickcheck-2.10:=[profile?]
+ dev-haskell/random:=[profile?]
+ dev-haskell/tagged:=[profile?]
+ >=dev-haskell/tasty-1.0.1:=[profile?]
+ >=dev-lang/ghc-8.4.3:=
+"
+DEPEND="${RDEPEND}
+ >=dev-haskell/cabal-2.2.0.1
+ test? ( dev-haskell/pcre-light
+ dev-haskell/tasty-hunit )
+"