summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-haskell/tasty-quickcheck')
-rw-r--r--dev-haskell/tasty-quickcheck/Manifest1
-rw-r--r--dev-haskell/tasty-quickcheck/metadata.xml4
-rw-r--r--dev-haskell/tasty-quickcheck/tasty-quickcheck-0.10.1.1.ebuild10
-rw-r--r--dev-haskell/tasty-quickcheck/tasty-quickcheck-0.10.2.ebuild29
4 files changed, 39 insertions, 5 deletions
diff --git a/dev-haskell/tasty-quickcheck/Manifest b/dev-haskell/tasty-quickcheck/Manifest
index 88ace228fe3e..233c20edb3c6 100644
--- a/dev-haskell/tasty-quickcheck/Manifest
+++ b/dev-haskell/tasty-quickcheck/Manifest
@@ -1 +1,2 @@
DIST tasty-quickcheck-0.10.1.1.tar.gz 5539 BLAKE2B 688675aa15f2790d147d34dbeca8d42e556b8a2d3fe52c7687e149f271a0ddcbb6fb21ac6be4065fdf1b8dcb82aa10a8f533e77da0111c140bb9ef807e48c222 SHA512 13cfcc99eb9988d4842327d96f0e58f5ba6c653d3027a4adb307d4101bc2f7deee0033197b4358a837ace0d03423bdafe2197b029da6a64d8b650ee2f5bd958d
+DIST tasty-quickcheck-0.10.2.tar.gz 5868 BLAKE2B 74a4870c547f716378fee7aae7e628ca69d3364f22cd62710ed0321abcbc2a94f48fe8a0c89e0aab62bf380247422ee5f0cb5fa122ab3e33219981a6e8ce4142 SHA512 78b223fc54428e71b1a8b3afba1128764e61703be4dea95541e0661d2fbe3006b77ef15200577e40bf3bf78a557f66f13a77288c8fe87dc19eb343c9fdff9d89
diff --git a/dev-haskell/tasty-quickcheck/metadata.xml b/dev-haskell/tasty-quickcheck/metadata.xml
index 937381521944..e9cd653d1c03 100644
--- a/dev-haskell/tasty-quickcheck/metadata.xml
+++ b/dev-haskell/tasty-quickcheck/metadata.xml
@@ -5,4 +5,8 @@
<email>haskell@gentoo.org</email>
<name>Gentoo Haskell</name>
</maintainer>
+ <upstream>
+ <remote-id type="hackage">tasty-quickcheck</remote-id>
+ <remote-id type="github">UnkindPartition/tasty</remote-id>
+ </upstream>
</pkgmetadata>
diff --git a/dev-haskell/tasty-quickcheck/tasty-quickcheck-0.10.1.1.ebuild b/dev-haskell/tasty-quickcheck/tasty-quickcheck-0.10.1.1.ebuild
index c5e7fb3b375a..2c998919b3f5 100644
--- a/dev-haskell/tasty-quickcheck/tasty-quickcheck-0.10.1.1.ebuild
+++ b/dev-haskell/tasty-quickcheck/tasty-quickcheck-0.10.1.1.ebuild
@@ -1,7 +1,7 @@
-# Copyright 1999-2020 Gentoo Authors
+# Copyright 1999-2023 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=7
+EAPI=8
# ebuild generated by hackport 0.6.4.9999
@@ -9,16 +9,16 @@ CABAL_FEATURES="lib profile haddock hoogle hscolour test-suite"
inherit haskell-cabal
DESCRIPTION="QuickCheck support for the Tasty test framework"
-HOMEPAGE="https://github.com/feuerbach/tasty"
+HOMEPAGE="https://github.com/UnkindPartition/tasty"
SRC_URI="https://hackage.haskell.org/package/${P}/${P}.tar.gz"
LICENSE="MIT"
SLOT="0/${PV}"
-KEYWORDS="~amd64 ~x86"
+KEYWORDS="amd64 ~arm64 ~ppc64 ~riscv ~x86"
IUSE=""
RDEPEND="dev-haskell/optparse-applicative:=[profile?]
- >=dev-haskell/quickcheck-2.10:2=[profile?]
+ >=dev-haskell/quickcheck-2.10:=[profile?]
dev-haskell/random:=[profile?]
dev-haskell/tagged:=[profile?]
>=dev-haskell/tasty-1.0.1:=[profile?]
diff --git a/dev-haskell/tasty-quickcheck/tasty-quickcheck-0.10.2.ebuild b/dev-haskell/tasty-quickcheck/tasty-quickcheck-0.10.2.ebuild
new file mode 100644
index 000000000000..f9bb7b4d7cf9
--- /dev/null
+++ b/dev-haskell/tasty-quickcheck/tasty-quickcheck-0.10.2.ebuild
@@ -0,0 +1,29 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+# ebuild generated by hackport 0.7.3.0
+
+CABAL_FEATURES="lib profile haddock hoogle hscolour test-suite"
+inherit haskell-cabal
+
+DESCRIPTION="QuickCheck support for the Tasty test framework"
+HOMEPAGE="https://github.com/UnkindPartition/tasty"
+
+LICENSE="MIT"
+SLOT="0/${PV}"
+KEYWORDS="~amd64 ~arm64 ~ppc64 ~riscv ~x86"
+
+RDEPEND="dev-haskell/optparse-applicative:=[profile?]
+ >=dev-haskell/quickcheck-2.10:=[profile?]
+ dev-haskell/random:=[profile?]
+ dev-haskell/tagged:=[profile?]
+ >=dev-haskell/tasty-1.0.1:=[profile?]
+ >=dev-lang/ghc-8.4.3:=
+"
+DEPEND="${RDEPEND}
+ >=dev-haskell/cabal-2.2.0.1
+ test? ( dev-haskell/pcre-light
+ dev-haskell/tasty-hunit )
+"