summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-lang/rust/rust-1.72.0-r1.ebuild')
-rw-r--r--dev-lang/rust/rust-1.72.0-r1.ebuild6
1 files changed, 3 insertions, 3 deletions
diff --git a/dev-lang/rust/rust-1.72.0-r1.ebuild b/dev-lang/rust/rust-1.72.0-r1.ebuild
index c4277fbefd8c..74a1d089fed6 100644
--- a/dev-lang/rust/rust-1.72.0-r1.ebuild
+++ b/dev-lang/rust/rust-1.72.0-r1.ebuild
@@ -3,7 +3,7 @@
EAPI=8
-PYTHON_COMPAT=( python3_{9..12} )
+PYTHON_COMPAT=( python3_{10..12} )
inherit bash-completion-r1 check-reqs estack flag-o-matic llvm multiprocessing \
multilib multilib-build python-any-r1 rust-toolchain toolchain-funcs verify-sig
@@ -98,7 +98,7 @@ BDEPEND="${PYTHON_DEPS}
>=dev-util/cmake-3.13.4
app-alternatives/ninja
)
- test? ( sys-devel/gdb )
+ test? ( dev-debug/gdb )
verify-sig? ( sec-keys/openpgp-keys-rust )
"
@@ -741,7 +741,7 @@ src_install() {
pkg_postinst() {
eselect rust update
- if has_version sys-devel/gdb || has_version dev-util/lldb; then
+ if has_version dev-debug/gdb || has_version dev-util/lldb; then
elog "Rust installs a helper script for calling GDB and LLDB,"
elog "for your convenience it is installed under /usr/bin/rust-{gdb,lldb}-${PV}."
fi