summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-lang')
-rw-r--r--dev-lang/rust/rust-1.65.0.ebuild6
-rw-r--r--dev-lang/rust/rust-1.66.1.ebuild6
-rw-r--r--dev-lang/rust/rust-1.67.1-r1.ebuild6
-rw-r--r--dev-lang/rust/rust-1.68.2.ebuild6
-rw-r--r--dev-lang/rust/rust-1.69.0-r1.ebuild6
-rw-r--r--dev-lang/rust/rust-1.70.0.ebuild6
-rw-r--r--dev-lang/rust/rust-1.71.0.ebuild6
-rw-r--r--dev-lang/rust/rust-1.71.1.ebuild6
-rw-r--r--dev-lang/rust/rust-1.72.0-r1.ebuild6
-rw-r--r--dev-lang/rust/rust-1.73.0.ebuild6
-rw-r--r--dev-lang/rust/rust-1.74.1.ebuild6
11 files changed, 33 insertions, 33 deletions
diff --git a/dev-lang/rust/rust-1.65.0.ebuild b/dev-lang/rust/rust-1.65.0.ebuild
index 1f262619cd79..7e54422b35e5 100644
--- a/dev-lang/rust/rust-1.65.0.ebuild
+++ b/dev-lang/rust/rust-1.65.0.ebuild
@@ -3,7 +3,7 @@
EAPI=8
-PYTHON_COMPAT=( python3_{9..11} )
+PYTHON_COMPAT=( python3_{10..11} )
inherit bash-completion-r1 check-reqs estack flag-o-matic llvm multiprocessing \
multilib multilib-build python-any-r1 rust-toolchain toolchain-funcs verify-sig
@@ -96,7 +96,7 @@ BDEPEND="${PYTHON_DEPS}
>=dev-util/cmake-3.13.4
app-alternatives/ninja
)
- test? ( sys-devel/gdb )
+ test? ( dev-debug/gdb )
verify-sig? ( sec-keys/openpgp-keys-rust )
"
@@ -735,7 +735,7 @@ src_install() {
pkg_postinst() {
eselect rust update
- if has_version sys-devel/gdb || has_version dev-util/lldb; then
+ if has_version dev-debug/gdb || has_version dev-util/lldb; then
elog "Rust installs a helper script for calling GDB and LLDB,"
elog "for your convenience it is installed under /usr/bin/rust-{gdb,lldb}-${PV}."
fi
diff --git a/dev-lang/rust/rust-1.66.1.ebuild b/dev-lang/rust/rust-1.66.1.ebuild
index a986d1c4b784..417000258c14 100644
--- a/dev-lang/rust/rust-1.66.1.ebuild
+++ b/dev-lang/rust/rust-1.66.1.ebuild
@@ -3,7 +3,7 @@
EAPI=8
-PYTHON_COMPAT=( python3_{9..11} )
+PYTHON_COMPAT=( python3_{10..11} )
inherit bash-completion-r1 check-reqs estack flag-o-matic llvm multiprocessing \
multilib multilib-build python-any-r1 rust-toolchain toolchain-funcs verify-sig
@@ -96,7 +96,7 @@ BDEPEND="${PYTHON_DEPS}
>=dev-util/cmake-3.13.4
app-alternatives/ninja
)
- test? ( sys-devel/gdb )
+ test? ( dev-debug/gdb )
verify-sig? ( sec-keys/openpgp-keys-rust )
"
@@ -733,7 +733,7 @@ src_install() {
pkg_postinst() {
eselect rust update
- if has_version sys-devel/gdb || has_version dev-util/lldb; then
+ if has_version dev-debug/gdb || has_version dev-util/lldb; then
elog "Rust installs a helper script for calling GDB and LLDB,"
elog "for your convenience it is installed under /usr/bin/rust-{gdb,lldb}-${PV}."
fi
diff --git a/dev-lang/rust/rust-1.67.1-r1.ebuild b/dev-lang/rust/rust-1.67.1-r1.ebuild
index dbd7af6c7240..f0070f3868fa 100644
--- a/dev-lang/rust/rust-1.67.1-r1.ebuild
+++ b/dev-lang/rust/rust-1.67.1-r1.ebuild
@@ -3,7 +3,7 @@
EAPI=8
-PYTHON_COMPAT=( python3_{9..11} )
+PYTHON_COMPAT=( python3_{10..11} )
inherit bash-completion-r1 check-reqs estack flag-o-matic llvm multiprocessing \
multilib multilib-build python-any-r1 rust-toolchain toolchain-funcs verify-sig
@@ -96,7 +96,7 @@ BDEPEND="${PYTHON_DEPS}
>=dev-util/cmake-3.13.4
app-alternatives/ninja
)
- test? ( sys-devel/gdb )
+ test? ( dev-debug/gdb )
verify-sig? ( sec-keys/openpgp-keys-rust )
"
@@ -724,7 +724,7 @@ src_install() {
pkg_postinst() {
eselect rust update
- if has_version sys-devel/gdb || has_version dev-util/lldb; then
+ if has_version dev-debug/gdb || has_version dev-util/lldb; then
elog "Rust installs a helper script for calling GDB and LLDB,"
elog "for your convenience it is installed under /usr/bin/rust-{gdb,lldb}-${PV}."
fi
diff --git a/dev-lang/rust/rust-1.68.2.ebuild b/dev-lang/rust/rust-1.68.2.ebuild
index 9645429fcf92..5f2084412bdc 100644
--- a/dev-lang/rust/rust-1.68.2.ebuild
+++ b/dev-lang/rust/rust-1.68.2.ebuild
@@ -3,7 +3,7 @@
EAPI=8
-PYTHON_COMPAT=( python3_{9..11} )
+PYTHON_COMPAT=( python3_{10..11} )
inherit bash-completion-r1 check-reqs estack flag-o-matic llvm multiprocessing \
multilib multilib-build python-any-r1 rust-toolchain toolchain-funcs verify-sig
@@ -96,7 +96,7 @@ BDEPEND="${PYTHON_DEPS}
>=dev-util/cmake-3.13.4
app-alternatives/ninja
)
- test? ( sys-devel/gdb )
+ test? ( dev-debug/gdb )
verify-sig? ( sec-keys/openpgp-keys-rust )
"
@@ -723,7 +723,7 @@ src_install() {
pkg_postinst() {
eselect rust update
- if has_version sys-devel/gdb || has_version dev-util/lldb; then
+ if has_version dev-debug/gdb || has_version dev-util/lldb; then
elog "Rust installs a helper script for calling GDB and LLDB,"
elog "for your convenience it is installed under /usr/bin/rust-{gdb,lldb}-${PV}."
fi
diff --git a/dev-lang/rust/rust-1.69.0-r1.ebuild b/dev-lang/rust/rust-1.69.0-r1.ebuild
index ffa8d42d6822..9d99f8cbeef2 100644
--- a/dev-lang/rust/rust-1.69.0-r1.ebuild
+++ b/dev-lang/rust/rust-1.69.0-r1.ebuild
@@ -3,7 +3,7 @@
EAPI=8
-PYTHON_COMPAT=( python3_{9..11} )
+PYTHON_COMPAT=( python3_{10..11} )
inherit bash-completion-r1 check-reqs estack flag-o-matic llvm multiprocessing \
multilib multilib-build python-any-r1 rust-toolchain toolchain-funcs verify-sig
@@ -96,7 +96,7 @@ BDEPEND="${PYTHON_DEPS}
>=dev-util/cmake-3.13.4
app-alternatives/ninja
)
- test? ( sys-devel/gdb )
+ test? ( dev-debug/gdb )
verify-sig? ( sec-keys/openpgp-keys-rust )
"
@@ -724,7 +724,7 @@ src_install() {
pkg_postinst() {
eselect rust update
- if has_version sys-devel/gdb || has_version dev-util/lldb; then
+ if has_version dev-debug/gdb || has_version dev-util/lldb; then
elog "Rust installs a helper script for calling GDB and LLDB,"
elog "for your convenience it is installed under /usr/bin/rust-{gdb,lldb}-${PV}."
fi
diff --git a/dev-lang/rust/rust-1.70.0.ebuild b/dev-lang/rust/rust-1.70.0.ebuild
index d9b78ad1a4d6..29ec567db15e 100644
--- a/dev-lang/rust/rust-1.70.0.ebuild
+++ b/dev-lang/rust/rust-1.70.0.ebuild
@@ -3,7 +3,7 @@
EAPI=8
-PYTHON_COMPAT=( python3_{9..12} )
+PYTHON_COMPAT=( python3_{10..12} )
inherit bash-completion-r1 check-reqs estack flag-o-matic llvm multiprocessing \
multilib multilib-build python-any-r1 rust-toolchain toolchain-funcs verify-sig
@@ -96,7 +96,7 @@ BDEPEND="${PYTHON_DEPS}
>=dev-util/cmake-3.13.4
app-alternatives/ninja
)
- test? ( sys-devel/gdb )
+ test? ( dev-debug/gdb )
verify-sig? ( sec-keys/openpgp-keys-rust )
"
@@ -727,7 +727,7 @@ src_install() {
pkg_postinst() {
eselect rust update
- if has_version sys-devel/gdb || has_version dev-util/lldb; then
+ if has_version dev-debug/gdb || has_version dev-util/lldb; then
elog "Rust installs a helper script for calling GDB and LLDB,"
elog "for your convenience it is installed under /usr/bin/rust-{gdb,lldb}-${PV}."
fi
diff --git a/dev-lang/rust/rust-1.71.0.ebuild b/dev-lang/rust/rust-1.71.0.ebuild
index 707d48f5834b..2952c0b21e22 100644
--- a/dev-lang/rust/rust-1.71.0.ebuild
+++ b/dev-lang/rust/rust-1.71.0.ebuild
@@ -3,7 +3,7 @@
EAPI=8
-PYTHON_COMPAT=( python3_{9..12} )
+PYTHON_COMPAT=( python3_{10..12} )
inherit bash-completion-r1 check-reqs estack flag-o-matic llvm multiprocessing \
multilib multilib-build python-any-r1 rust-toolchain toolchain-funcs verify-sig
@@ -96,7 +96,7 @@ BDEPEND="${PYTHON_DEPS}
>=dev-util/cmake-3.13.4
app-alternatives/ninja
)
- test? ( sys-devel/gdb )
+ test? ( dev-debug/gdb )
verify-sig? ( sec-keys/openpgp-keys-rust )
"
@@ -729,7 +729,7 @@ src_install() {
pkg_postinst() {
eselect rust update
- if has_version sys-devel/gdb || has_version dev-util/lldb; then
+ if has_version dev-debug/gdb || has_version dev-util/lldb; then
elog "Rust installs a helper script for calling GDB and LLDB,"
elog "for your convenience it is installed under /usr/bin/rust-{gdb,lldb}-${PV}."
fi
diff --git a/dev-lang/rust/rust-1.71.1.ebuild b/dev-lang/rust/rust-1.71.1.ebuild
index 77ac02a5b1b4..eb48a05f0cb4 100644
--- a/dev-lang/rust/rust-1.71.1.ebuild
+++ b/dev-lang/rust/rust-1.71.1.ebuild
@@ -3,7 +3,7 @@
EAPI=8
-PYTHON_COMPAT=( python3_{9..12} )
+PYTHON_COMPAT=( python3_{10..12} )
inherit bash-completion-r1 check-reqs estack flag-o-matic llvm multiprocessing \
multilib multilib-build python-any-r1 rust-toolchain toolchain-funcs verify-sig
@@ -96,7 +96,7 @@ BDEPEND="${PYTHON_DEPS}
>=dev-util/cmake-3.13.4
app-alternatives/ninja
)
- test? ( sys-devel/gdb )
+ test? ( dev-debug/gdb )
verify-sig? ( sec-keys/openpgp-keys-rust )
"
@@ -729,7 +729,7 @@ src_install() {
pkg_postinst() {
eselect rust update
- if has_version sys-devel/gdb || has_version dev-util/lldb; then
+ if has_version dev-debug/gdb || has_version dev-util/lldb; then
elog "Rust installs a helper script for calling GDB and LLDB,"
elog "for your convenience it is installed under /usr/bin/rust-{gdb,lldb}-${PV}."
fi
diff --git a/dev-lang/rust/rust-1.72.0-r1.ebuild b/dev-lang/rust/rust-1.72.0-r1.ebuild
index c4277fbefd8c..74a1d089fed6 100644
--- a/dev-lang/rust/rust-1.72.0-r1.ebuild
+++ b/dev-lang/rust/rust-1.72.0-r1.ebuild
@@ -3,7 +3,7 @@
EAPI=8
-PYTHON_COMPAT=( python3_{9..12} )
+PYTHON_COMPAT=( python3_{10..12} )
inherit bash-completion-r1 check-reqs estack flag-o-matic llvm multiprocessing \
multilib multilib-build python-any-r1 rust-toolchain toolchain-funcs verify-sig
@@ -98,7 +98,7 @@ BDEPEND="${PYTHON_DEPS}
>=dev-util/cmake-3.13.4
app-alternatives/ninja
)
- test? ( sys-devel/gdb )
+ test? ( dev-debug/gdb )
verify-sig? ( sec-keys/openpgp-keys-rust )
"
@@ -741,7 +741,7 @@ src_install() {
pkg_postinst() {
eselect rust update
- if has_version sys-devel/gdb || has_version dev-util/lldb; then
+ if has_version dev-debug/gdb || has_version dev-util/lldb; then
elog "Rust installs a helper script for calling GDB and LLDB,"
elog "for your convenience it is installed under /usr/bin/rust-{gdb,lldb}-${PV}."
fi
diff --git a/dev-lang/rust/rust-1.73.0.ebuild b/dev-lang/rust/rust-1.73.0.ebuild
index efb165def423..ed86aaf8be4f 100644
--- a/dev-lang/rust/rust-1.73.0.ebuild
+++ b/dev-lang/rust/rust-1.73.0.ebuild
@@ -3,7 +3,7 @@
EAPI=8
-PYTHON_COMPAT=( python3_{9..12} )
+PYTHON_COMPAT=( python3_{10..12} )
inherit bash-completion-r1 check-reqs estack flag-o-matic llvm multiprocessing \
multilib multilib-build python-any-r1 rust-toolchain toolchain-funcs verify-sig
@@ -97,7 +97,7 @@ BDEPEND="${PYTHON_DEPS}
>=dev-util/cmake-3.13.4
app-alternatives/ninja
)
- test? ( sys-devel/gdb )
+ test? ( dev-debug/gdb )
verify-sig? ( sec-keys/openpgp-keys-rust )
"
@@ -740,7 +740,7 @@ src_install() {
pkg_postinst() {
eselect rust update
- if has_version sys-devel/gdb || has_version dev-util/lldb; then
+ if has_version dev-debug/gdb || has_version dev-util/lldb; then
elog "Rust installs a helper script for calling GDB and LLDB,"
elog "for your convenience it is installed under /usr/bin/rust-{gdb,lldb}-${PV}."
fi
diff --git a/dev-lang/rust/rust-1.74.1.ebuild b/dev-lang/rust/rust-1.74.1.ebuild
index c623e2cd593d..157fd271cdaa 100644
--- a/dev-lang/rust/rust-1.74.1.ebuild
+++ b/dev-lang/rust/rust-1.74.1.ebuild
@@ -3,7 +3,7 @@
EAPI=8
-PYTHON_COMPAT=( python3_{9..12} )
+PYTHON_COMPAT=( python3_{10..12} )
inherit bash-completion-r1 check-reqs estack flag-o-matic llvm multiprocessing \
multilib multilib-build python-any-r1 rust-toolchain toolchain-funcs verify-sig
@@ -97,7 +97,7 @@ BDEPEND="${PYTHON_DEPS}
>=dev-util/cmake-3.13.4
app-alternatives/ninja
)
- test? ( sys-devel/gdb )
+ test? ( dev-debug/gdb )
verify-sig? ( sec-keys/openpgp-keys-rust )
"
@@ -741,7 +741,7 @@ src_install() {
pkg_postinst() {
eselect rust update
- if has_version sys-devel/gdb || has_version dev-util/lldb; then
+ if has_version dev-debug/gdb || has_version dev-util/lldb; then
elog "Rust installs a helper script for calling GDB and LLDB,"
elog "for your convenience it is installed under /usr/bin/rust-{gdb,lldb}-${PV}."
fi