summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-libs/capnproto/capnproto-0.9.1.ebuild')
-rw-r--r--dev-libs/capnproto/capnproto-0.9.1.ebuild10
1 files changed, 8 insertions, 2 deletions
diff --git a/dev-libs/capnproto/capnproto-0.9.1.ebuild b/dev-libs/capnproto/capnproto-0.9.1.ebuild
index ff77790127b8..9f31c01fca12 100644
--- a/dev-libs/capnproto/capnproto-0.9.1.ebuild
+++ b/dev-libs/capnproto/capnproto-0.9.1.ebuild
@@ -3,7 +3,7 @@
EAPI=8
-inherit cmake
+inherit cmake flag-o-matic
DESCRIPTION="RPC/Serialization system with capabilities support"
HOMEPAGE="https://capnproto.org"
@@ -12,7 +12,7 @@ S="${WORKDIR}"/${P}/c++
LICENSE="MIT"
SLOT="0/091"
-KEYWORDS="~amd64 ~arm ~arm64 ~ppc ~ppc64 ~x86"
+KEYWORDS="amd64 ~arm arm64 ppc ppc64 x86"
IUSE="+ssl test zlib"
RESTRICT="!test? ( test )"
@@ -26,6 +26,12 @@ DEPEND="${RDEPEND}
"
src_configure() {
+ if use arm || use ppc || use mips || [[ ${CHOST} == *i486* ]] ; then
+ # append-libs won't work here, cmake doesn't respect it
+ # ... and ldflags gets missed once
+ append-flags -latomic
+ fi
+
local mycmakeargs=(
-DWITH_OPENSSL=$(usex ssl)
-DBUILD_TESTING=$(usex test)