summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-libs/capnproto')
-rw-r--r--dev-libs/capnproto/Manifest4
-rw-r--r--dev-libs/capnproto/capnproto-0.10.2.ebuild49
-rw-r--r--dev-libs/capnproto/capnproto-0.10.4-r1.ebuild46
-rw-r--r--dev-libs/capnproto/capnproto-0.7.0.ebuild39
-rw-r--r--dev-libs/capnproto/capnproto-0.8.0.ebuild45
-rw-r--r--dev-libs/capnproto/capnproto-0.9.1.ebuild10
-rw-r--r--dev-libs/capnproto/files/capnproto-0.10.2-gcc-13.patch21
7 files changed, 126 insertions, 88 deletions
diff --git a/dev-libs/capnproto/Manifest b/dev-libs/capnproto/Manifest
index d4db69afc68d..84e5ab808603 100644
--- a/dev-libs/capnproto/Manifest
+++ b/dev-libs/capnproto/Manifest
@@ -1,3 +1,3 @@
-DIST capnproto-0.7.0.tar.gz 1983172 BLAKE2B d88b5f8e3278f8e3aceccdc459001b99328b0440812352dcb6b54bd11e18aa7fee6d337252841c86e9c3eb1afcdbd99884c965156d6cec37e3c0996c9ec1241f SHA512 a3ea278ded6a866759c0517d16b99bd38ffea1c163ce63a3604b752d8bdaafbc38a600de94afe12db35e7f7f06e29cc94c911dc2e0ecec6fe1185452df2a2bd3
-DIST capnproto-0.8.0.tar.gz 2121249 BLAKE2B 6d4ef9adb026a8ea8bc558bed1f8ce910e9c3b050ad0ac7ebd4be323cc1709a6b08956d4d2f39daee5c6485438f64695a028ea198aaae8a6c366316f10b1a64f SHA512 a3b87d47f4c160c3c72304539c3d2a6836488a50d1014c9f0eb95c112dc1e0f85b3158d26c248eff464205388ea61733c45ba10dc5441e5dd04064ba2c7970e6
+DIST capnproto-0.10.2.tar.gz 2279393 BLAKE2B d78442bc122bc976fb636dfde694e10414bf3468ead903fac7ba59cbd81a49ce94969954fdc90f92f7f58f0af80f2da1f70de9b461d99fc6ae9a9e7aa9cd0500 SHA512 079ab715ea19ac207f72bb4874ab6362c11dfb9128342ec937e3f4d27e4100530cf9e6a0275eaca1e45a1bb706b65179a526ea8cfceba93bb36cd6c4f1c0cf5b
+DIST capnproto-0.10.4.tar.gz 2280389 BLAKE2B 3a893b766302a96df71763613fa1624f6b7229b8926099d1d9c217f4a1817db16aa24d3bec7950e480da6b027bd9b6b0b5a4083e982e7bda8fc6594794fd379a SHA512 6179a202399f4391014827799c954e0b3ad811ab82ebd0addc01d8c7695b9c1a9c0a0c26b018cd392e3731e12b30cca58545459d1b3a140e86e34b75d7eacbc7
DIST capnproto-0.9.1.tar.gz 2238849 BLAKE2B f8de56c7f79b0ddad35f3e8fec7740510ca2328e4ddc633a71420901d3fc44df44d807c3965213dfc2535bbe03832c5164242d33cd0bff901d6f288fb62bab21 SHA512 bdc5960f26214139744d768ca4558b085e2d359c375a8849ca532a4c458a2daf0ee1a1f4d00745de5abf353aa1e4084a2d85e5523006f23f591f21fac2d847fd
diff --git a/dev-libs/capnproto/capnproto-0.10.2.ebuild b/dev-libs/capnproto/capnproto-0.10.2.ebuild
new file mode 100644
index 000000000000..2c126974f18a
--- /dev/null
+++ b/dev-libs/capnproto/capnproto-0.10.2.ebuild
@@ -0,0 +1,49 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit cmake flag-o-matic
+
+DESCRIPTION="RPC/Serialization system with capabilities support"
+HOMEPAGE="https://capnproto.org"
+SRC_URI="https://github.com/sandstorm-io/capnproto/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+S="${WORKDIR}"/${P}/c++
+
+LICENSE="MIT"
+SLOT="0/091"
+KEYWORDS="~amd64 ~arm ~arm64 ~ppc ~ppc64 ~riscv ~x86"
+IUSE="+ssl test zlib"
+
+RESTRICT="!test? ( test )"
+
+RDEPEND="
+ ssl? ( dev-libs/openssl:0= )
+ zlib? ( sys-libs/zlib:0= )
+"
+DEPEND="${RDEPEND}
+ test? ( dev-cpp/gtest )
+"
+
+PATCHES=(
+ "${FILESDIR}"/${P}-gcc-13.patch
+)
+
+src_configure() {
+ if use arm || use ppc || use mips || [[ ${CHOST} == *i486* ]] ; then
+ # append-libs won't work here, cmake doesn't respect it
+ # ... and ldflags gets missed once
+ append-flags -latomic
+ fi
+
+ local mycmakeargs=(
+ -DWITH_OPENSSL=$(usex ssl)
+ -DBUILD_TESTING=$(usex test)
+ $(cmake_use_find_package zlib ZLIB)
+ )
+ cmake_src_configure
+}
+
+src_test() {
+ cmake_build check
+}
diff --git a/dev-libs/capnproto/capnproto-0.10.4-r1.ebuild b/dev-libs/capnproto/capnproto-0.10.4-r1.ebuild
new file mode 100644
index 000000000000..ce80f057da1e
--- /dev/null
+++ b/dev-libs/capnproto/capnproto-0.10.4-r1.ebuild
@@ -0,0 +1,46 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit cmake flag-o-matic
+
+DESCRIPTION="RPC/Serialization system with capabilities support"
+HOMEPAGE="https://capnproto.org"
+SRC_URI="https://github.com/sandstorm-io/capnproto/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+S="${WORKDIR}"/${P}/c++
+
+LICENSE="MIT"
+SLOT="0/${PV}"
+KEYWORDS="~amd64 ~arm ~arm64 ~loong ~ppc ~ppc64 ~riscv ~x86"
+IUSE="+ssl test zlib"
+
+RESTRICT="!test? ( test )"
+
+RDEPEND="
+ ssl? ( dev-libs/openssl:= )
+ zlib? ( sys-libs/zlib:= )
+"
+DEPEND="${RDEPEND}
+ test? ( dev-cpp/gtest )
+"
+
+src_configure() {
+ append-atomic-flags
+ if [[ ${LIBS} == *atomic* ]] ; then
+ # append-libs won't work here, cmake doesn't respect it
+ # ... and ldflags gets missed once
+ append-flags -latomic
+ fi
+
+ local mycmakeargs=(
+ -DWITH_OPENSSL=$(usex ssl)
+ -DBUILD_TESTING=$(usex test)
+ $(cmake_use_find_package zlib ZLIB)
+ )
+ cmake_src_configure
+}
+
+src_test() {
+ cmake_build check
+}
diff --git a/dev-libs/capnproto/capnproto-0.7.0.ebuild b/dev-libs/capnproto/capnproto-0.7.0.ebuild
deleted file mode 100644
index 9279dffeaef8..000000000000
--- a/dev-libs/capnproto/capnproto-0.7.0.ebuild
+++ /dev/null
@@ -1,39 +0,0 @@
-# Copyright 1999-2021 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=7
-
-inherit autotools
-
-DESCRIPTION="RPC/Serialization system with capabilities support"
-HOMEPAGE="https://capnproto.org"
-SRC_URI="https://github.com/sandstorm-io/capnproto/archive/v${PV}.tar.gz -> ${P}.tar.gz"
-
-LICENSE="MIT"
-SLOT="0/070"
-KEYWORDS="amd64 ~arm arm64 x86"
-IUSE="+ssl static-libs test"
-RESTRICT="!test? ( test )"
-
-RDEPEND="ssl? ( dev-libs/openssl:0= )"
-DEPEND="${RDEPEND} test? ( dev-cpp/gtest )"
-
-S=${WORKDIR}/${P}/c++
-
-src_prepare() {
- sed -e 's/ldconfig/true/' -i Makefile.am || die
- sed -e 's#gtest/lib/libgtest.la gtest/lib/libgtest_main.la#-lgtest -lgtest_main#' -i Makefile.am || die
- default
- eautoreconf
-}
-
-src_configure() {
- econf \
- $(use_enable static-libs static) \
- $(use_with ssl openssl)
-}
-
-src_install() {
- default
- find "${ED}" -name '*.la' -delete
-}
diff --git a/dev-libs/capnproto/capnproto-0.8.0.ebuild b/dev-libs/capnproto/capnproto-0.8.0.ebuild
deleted file mode 100644
index 396f01c7ef9a..000000000000
--- a/dev-libs/capnproto/capnproto-0.8.0.ebuild
+++ /dev/null
@@ -1,45 +0,0 @@
-# Copyright 1999-2021 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=7
-
-inherit autotools
-
-DESCRIPTION="RPC/Serialization system with capabilities support"
-HOMEPAGE="https://capnproto.org"
-SRC_URI="https://github.com/sandstorm-io/capnproto/archive/v${PV}.tar.gz -> ${P}.tar.gz"
-
-LICENSE="MIT"
-SLOT="0/080"
-KEYWORDS="~amd64 ~arm ~arm64 ~ppc ~ppc64 ~x86"
-IUSE="+ssl static-libs test zlib"
-RESTRICT="!test? ( test )"
-
-RDEPEND="
- ssl? (
- dev-libs/openssl:0=
- )
- zlib? ( sys-libs/zlib:0= )
-"
-DEPEND="${RDEPEND} test? ( dev-cpp/gtest )"
-
-S=${WORKDIR}/${P}/c++
-
-src_prepare() {
- sed -e 's/ldconfig/true/' -i Makefile.am || die
- sed -e 's#gtest/lib/libgtest.la gtest/lib/libgtest_main.la#-lgtest -lgtest_main#' -i Makefile.am || die
- default
- eautoreconf
-}
-
-src_configure() {
- econf \
- $(use_enable static-libs static) \
- $(use_with ssl openssl) \
- $(use_with zlib)
-}
-
-src_install() {
- default
- find "${ED}" -name '*.la' -delete
-}
diff --git a/dev-libs/capnproto/capnproto-0.9.1.ebuild b/dev-libs/capnproto/capnproto-0.9.1.ebuild
index ff77790127b8..9f31c01fca12 100644
--- a/dev-libs/capnproto/capnproto-0.9.1.ebuild
+++ b/dev-libs/capnproto/capnproto-0.9.1.ebuild
@@ -3,7 +3,7 @@
EAPI=8
-inherit cmake
+inherit cmake flag-o-matic
DESCRIPTION="RPC/Serialization system with capabilities support"
HOMEPAGE="https://capnproto.org"
@@ -12,7 +12,7 @@ S="${WORKDIR}"/${P}/c++
LICENSE="MIT"
SLOT="0/091"
-KEYWORDS="~amd64 ~arm ~arm64 ~ppc ~ppc64 ~x86"
+KEYWORDS="amd64 ~arm arm64 ppc ppc64 x86"
IUSE="+ssl test zlib"
RESTRICT="!test? ( test )"
@@ -26,6 +26,12 @@ DEPEND="${RDEPEND}
"
src_configure() {
+ if use arm || use ppc || use mips || [[ ${CHOST} == *i486* ]] ; then
+ # append-libs won't work here, cmake doesn't respect it
+ # ... and ldflags gets missed once
+ append-flags -latomic
+ fi
+
local mycmakeargs=(
-DWITH_OPENSSL=$(usex ssl)
-DBUILD_TESTING=$(usex test)
diff --git a/dev-libs/capnproto/files/capnproto-0.10.2-gcc-13.patch b/dev-libs/capnproto/files/capnproto-0.10.2-gcc-13.patch
new file mode 100644
index 000000000000..576e785437da
--- /dev/null
+++ b/dev-libs/capnproto/files/capnproto-0.10.2-gcc-13.patch
@@ -0,0 +1,21 @@
+https://github.com/capnproto/capnproto/commit/1ae1e9990c7603f0dc99e64470f96693f869b00a
+
+From 1ae1e9990c7603f0dc99e64470f96693f869b00a Mon Sep 17 00:00:00 2001
+From: Heiko Becker <mail@heiko-becker.de>
+Date: Wed, 25 Jan 2023 23:40:27 +0100
+Subject: [PATCH] Fix build with gcc 13 by including <stdint.h> (#1613)
+
+Like other versions before, gcc 13 moved some includes around and as
+a result <stdint.h> is no longer transitively included. Explicitly
+include it for uint8_t.
+--- a/src/kj/string-test.c++
++++ b/src/kj/string-test.c++
+@@ -24,6 +24,7 @@
+ #include <string>
+ #include "vector.h"
+ #include <locale.h>
++#include <stdint.h>
+
+ namespace kj {
+ namespace _ { // private
+