summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-libs/libixion/libixion-0.15.0.ebuild')
-rw-r--r--dev-libs/libixion/libixion-0.15.0.ebuild15
1 files changed, 9 insertions, 6 deletions
diff --git a/dev-libs/libixion/libixion-0.15.0.ebuild b/dev-libs/libixion/libixion-0.15.0.ebuild
index d3155185dc5a..b93481abbcaf 100644
--- a/dev-libs/libixion/libixion-0.15.0.ebuild
+++ b/dev-libs/libixion/libixion-0.15.0.ebuild
@@ -4,14 +4,14 @@
EAPI=7
PYTHON_COMPAT=( python3_{6,7,8} )
-inherit python-single-r1
+inherit autotools python-single-r1
DESCRIPTION="General purpose formula parser & interpreter"
HOMEPAGE="https://gitlab.com/ixion/ixion"
if [[ ${PV} == *9999 ]]; then
EGIT_REPO_URI="https://gitlab.com/ixion/ixion.git"
- inherit git-r3 autotools
+ inherit git-r3
else
SRC_URI="https://kohei.us/files/ixion/src/${P}.tar.xz"
KEYWORDS="amd64 ~arm arm64 ~ppc ~ppc64 ~x86"
@@ -19,7 +19,7 @@ fi
LICENSE="MIT"
SLOT="0/0.15" # based on SONAME of libixion.so
-IUSE="debug python static-libs +threads"
+IUSE="debug python +threads"
REQUIRED_USE="python? ( ${PYTHON_REQUIRED_USE} )"
@@ -32,7 +32,10 @@ DEPEND="${RDEPEND}
dev-libs/spdlog
"
-PATCHES=( "${FILESDIR}/${P}-musl-clang.patch" ) # bug 714018
+PATCHES=(
+ "${FILESDIR}/${P}-musl-clang.patch" # bug 714018
+ "${FILESDIR}/${P}-bashism.patch" # bug 723128
+)
pkg_setup() {
use python && python-single-r1_pkg_setup
@@ -40,14 +43,14 @@ pkg_setup() {
src_prepare() {
default
- [[ ${PV} == *9999 ]] && eautoreconf
+ eautoreconf
}
src_configure() {
local myeconfargs=(
+ --disable-static
$(use_enable debug)
$(use_enable python)
- $(use_enable static-libs static)
$(use_enable threads)
)
econf "${myeconfargs[@]}"