summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-libs/libixion')
-rw-r--r--dev-libs/libixion/files/libixion-0.15.0-bashism.patch32
-rw-r--r--dev-libs/libixion/libixion-0.15.0.ebuild15
-rw-r--r--dev-libs/libixion/libixion-9999.ebuild4
3 files changed, 43 insertions, 8 deletions
diff --git a/dev-libs/libixion/files/libixion-0.15.0-bashism.patch b/dev-libs/libixion/files/libixion-0.15.0-bashism.patch
new file mode 100644
index 000000000000..9df7b04a865c
--- /dev/null
+++ b/dev-libs/libixion/files/libixion-0.15.0-bashism.patch
@@ -0,0 +1,32 @@
+From 076f6576e7398842457d34fd68140512795c7e00 Mon Sep 17 00:00:00 2001
+From: Lars Wendler <polynomial-c@gentoo.org>
+Date: Fri, 15 May 2020 12:42:20 +0200
+Subject: [PATCH] configure.ac: avoid bashisms
+
+or else we end up with unpredictable results if shell != /bin/bash:
+
+ ./configure: 19427: test: xno: unexpected operator
+
+Reported-by: Matt Whitlock <gentoo@mattwhitlock.name>
+Gentoo-bug: https://bugs.gentoo.org/723128
+Signed-off-by: Lars Wendler <polynomial-c@gentoo.org>
+---
+ configure.ac | 2 +-
+ 1 file changed, 1 insertion(+), 1 deletion(-)
+
+diff --git a/configure.ac b/configure.ac
+index 3a07dd8..505aeba 100644
+--- a/configure.ac
++++ b/configure.ac
+@@ -182,7 +182,7 @@ AC_ARG_ENABLE([werror],
+ [enable_werror="$enableval"],
+ [enable_werror=no]
+ )
+-AS_IF([test x"$enable_werror" == "xyes"], [
++AS_IF([test x"$enable_werror" = "xyes"], [
+ CXXFLAGS="$CXXFLAGS -Werror"
+ ])
+
+--
+2.26.2
+
diff --git a/dev-libs/libixion/libixion-0.15.0.ebuild b/dev-libs/libixion/libixion-0.15.0.ebuild
index d3155185dc5a..b93481abbcaf 100644
--- a/dev-libs/libixion/libixion-0.15.0.ebuild
+++ b/dev-libs/libixion/libixion-0.15.0.ebuild
@@ -4,14 +4,14 @@
EAPI=7
PYTHON_COMPAT=( python3_{6,7,8} )
-inherit python-single-r1
+inherit autotools python-single-r1
DESCRIPTION="General purpose formula parser & interpreter"
HOMEPAGE="https://gitlab.com/ixion/ixion"
if [[ ${PV} == *9999 ]]; then
EGIT_REPO_URI="https://gitlab.com/ixion/ixion.git"
- inherit git-r3 autotools
+ inherit git-r3
else
SRC_URI="https://kohei.us/files/ixion/src/${P}.tar.xz"
KEYWORDS="amd64 ~arm arm64 ~ppc ~ppc64 ~x86"
@@ -19,7 +19,7 @@ fi
LICENSE="MIT"
SLOT="0/0.15" # based on SONAME of libixion.so
-IUSE="debug python static-libs +threads"
+IUSE="debug python +threads"
REQUIRED_USE="python? ( ${PYTHON_REQUIRED_USE} )"
@@ -32,7 +32,10 @@ DEPEND="${RDEPEND}
dev-libs/spdlog
"
-PATCHES=( "${FILESDIR}/${P}-musl-clang.patch" ) # bug 714018
+PATCHES=(
+ "${FILESDIR}/${P}-musl-clang.patch" # bug 714018
+ "${FILESDIR}/${P}-bashism.patch" # bug 723128
+)
pkg_setup() {
use python && python-single-r1_pkg_setup
@@ -40,14 +43,14 @@ pkg_setup() {
src_prepare() {
default
- [[ ${PV} == *9999 ]] && eautoreconf
+ eautoreconf
}
src_configure() {
local myeconfargs=(
+ --disable-static
$(use_enable debug)
$(use_enable python)
- $(use_enable static-libs static)
$(use_enable threads)
)
econf "${myeconfargs[@]}"
diff --git a/dev-libs/libixion/libixion-9999.ebuild b/dev-libs/libixion/libixion-9999.ebuild
index 28084226f1e7..e3b55ff91012 100644
--- a/dev-libs/libixion/libixion-9999.ebuild
+++ b/dev-libs/libixion/libixion-9999.ebuild
@@ -21,7 +21,7 @@ fi
LICENSE="MIT"
SLOT="0/0.16" # based on SONAME of libixion.so
-IUSE="debug python static-libs +threads"
+IUSE="debug python +threads"
REQUIRED_USE="python? ( ${PYTHON_REQUIRED_USE} )"
@@ -45,9 +45,9 @@ src_prepare() {
src_configure() {
local myeconfargs=(
+ --disable-static
$(use_enable debug)
$(use_enable python)
- $(use_enable static-libs static)
$(use_enable threads)
)
econf "${myeconfargs[@]}"