summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-libs/libixion')
-rw-r--r--dev-libs/libixion/Manifest1
-rw-r--r--dev-libs/libixion/libixion-0.16.1.ebuild59
-rw-r--r--dev-libs/libixion/libixion-9999.ebuild10
3 files changed, 65 insertions, 5 deletions
diff --git a/dev-libs/libixion/Manifest b/dev-libs/libixion/Manifest
index 421f04ea458f..e4e60e0c3e73 100644
--- a/dev-libs/libixion/Manifest
+++ b/dev-libs/libixion/Manifest
@@ -1 +1,2 @@
DIST libixion-0.15.0.tar.xz 447388 BLAKE2B 55df3417783f1653b0aa4b80a5f0107a3794fcb403c1c1263ce9829b31ee5263a104fa210be151535c1ff091d5dc2519f694ef3cdb16074f86dab4d48a127afd SHA512 feecaa4a8e6191649a7ecbc6c0f4d7db6dba3a5e4a031c1f55236907bf94e2ece9ee05d18ed345e3503cffb4a380b04f6c4941ef4214ddf92687998a070b7543
+DIST libixion-0.16.1.tar.xz 482500 BLAKE2B 26075c819a952f48c4e136fa28b4ef5075b455dea52d51940e4fc55344e19e404d70b44222631d0b0f85280d09bb8a05955bfcbe0a228b97d72d8f00f1639248 SHA512 979c631e9536f6d2c3ae32f7892756ac8889d27c551d80eb9d519bf912bd323da4b6ecd363fe2719e74e04bc3661e5d56e03a582f68f5293ffcac59b74f4c7de
diff --git a/dev-libs/libixion/libixion-0.16.1.ebuild b/dev-libs/libixion/libixion-0.16.1.ebuild
new file mode 100644
index 000000000000..52f2afa3ce6f
--- /dev/null
+++ b/dev-libs/libixion/libixion-0.16.1.ebuild
@@ -0,0 +1,59 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python3_{7,8,9} )
+inherit python-single-r1
+
+DESCRIPTION="General purpose formula parser & interpreter"
+HOMEPAGE="https://gitlab.com/ixion/ixion"
+
+if [[ ${PV} == *9999 ]]; then
+ MDDS_SLOT="1/9999"
+ EGIT_REPO_URI="https://gitlab.com/ixion/ixion.git"
+ inherit git-r3 autotools
+else
+ MDDS_SLOT="1/1.5"
+ SRC_URI="https://kohei.us/files/ixion/src/${P}.tar.xz"
+# KEYWORDS="~amd64 ~arm ~arm64 ~ppc ~ppc64 ~x86"
+fi
+
+LICENSE="MIT"
+SLOT="0/0.16" # based on SONAME of libixion.so
+IUSE="debug python +threads"
+
+REQUIRED_USE="python? ( ${PYTHON_REQUIRED_USE} )"
+
+RDEPEND="
+ dev-libs/boost:=
+ dev-util/mdds:${MDDS_SLOT}
+ python? ( ${PYTHON_DEPS} )
+"
+DEPEND="${RDEPEND}"
+
+pkg_setup() {
+ use python && python-single-r1_pkg_setup
+}
+
+src_prepare() {
+ default
+ [[ ${PV} == *9999 ]] && eautoreconf
+}
+
+src_configure() {
+ local myeconfargs=(
+ --disable-static
+ $(use_enable debug)
+ $(use_enable debug debug-utils)
+ $(use_enable debug log-debug)
+ $(use_enable python)
+ $(use_enable threads)
+ )
+ econf "${myeconfargs[@]}"
+}
+
+src_install() {
+ default
+ find "${D}" -name '*.la' -type f -delete || die
+}
diff --git a/dev-libs/libixion/libixion-9999.ebuild b/dev-libs/libixion/libixion-9999.ebuild
index c1793b33a8dc..96e5b7ce6f18 100644
--- a/dev-libs/libixion/libixion-9999.ebuild
+++ b/dev-libs/libixion/libixion-9999.ebuild
@@ -1,9 +1,9 @@
-# Copyright 1999-2020 Gentoo Authors
+# Copyright 1999-2021 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=7
-PYTHON_COMPAT=( python3_{7,8} )
+PYTHON_COMPAT=( python3_{7,8,9} )
inherit python-single-r1
DESCRIPTION="General purpose formula parser & interpreter"
@@ -30,9 +30,7 @@ RDEPEND="
dev-util/mdds:${MDDS_SLOT}
python? ( ${PYTHON_DEPS} )
"
-DEPEND="${RDEPEND}
- dev-libs/spdlog
-"
+DEPEND="${RDEPEND}"
pkg_setup() {
use python && python-single-r1_pkg_setup
@@ -47,6 +45,8 @@ src_configure() {
local myeconfargs=(
--disable-static
$(use_enable debug)
+ $(use_enable debug debug-utils)
+ $(use_enable debug log-debug)
$(use_enable python)
$(use_enable threads)
)