summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-libs/liborcus/liborcus-9999.ebuild')
-rw-r--r--dev-libs/liborcus/liborcus-9999.ebuild30
1 files changed, 16 insertions, 14 deletions
diff --git a/dev-libs/liborcus/liborcus-9999.ebuild b/dev-libs/liborcus/liborcus-9999.ebuild
index 0ae4b1aa76b6..3aecf4036ad7 100644
--- a/dev-libs/liborcus/liborcus-9999.ebuild
+++ b/dev-libs/liborcus/liborcus-9999.ebuild
@@ -1,27 +1,30 @@
-# Copyright 1999-2020 Gentoo Authors
+# Copyright 1999-2024 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=7
+EAPI=8
-PYTHON_COMPAT=( python3_{6,7,8} )
-inherit python-single-r1
+PYTHON_COMPAT=( python3_{10..12} )
+inherit autotools python-single-r1
DESCRIPTION="Standalone file import filter library for spreadsheet documents"
HOMEPAGE="https://gitlab.com/orcus/orcus/blob/master/README.md"
if [[ ${PV} == *9999* ]]; then
- MDDS_SLOT="1/9999"
+ MDDS_SLOT="1/3.0"
EGIT_REPO_URI="https://gitlab.com/orcus/orcus.git"
- inherit git-r3 autotools
+ inherit git-r3
else
- MDDS_SLOT="1/1.5"
+ MDDS_SLOT="1/2.1"
SRC_URI="https://kohei.us/files/orcus/src/${P}.tar.xz"
- KEYWORDS="~amd64 ~arm ~arm64 ~ppc ~ppc64 ~x86"
+ KEYWORDS="~amd64 ~arm ~arm64 ~loong ~ppc ~ppc64 ~riscv ~x86"
fi
LICENSE="MIT"
-SLOT="0/0.16" # based on SONAME of liborcus.so
-IUSE="python +spreadsheet-model static-libs tools"
+SLOT="0/0.20" # based on SONAME of liborcus.so
+IUSE="python +spreadsheet-model test tools"
+
+REQUIRED_USE="python? ( ${PYTHON_REQUIRED_USE} )"
+RESTRICT="!test? ( test )"
RDEPEND="
dev-libs/boost:=[zlib(+)]
@@ -33,23 +36,21 @@ DEPEND="${RDEPEND}
dev-util/mdds:${MDDS_SLOT}
"
-REQUIRED_USE="python? ( ${PYTHON_REQUIRED_USE} )"
-
pkg_setup() {
use python && python-single-r1_pkg_setup
}
src_prepare() {
default
- [[ ${PV} == *9999 ]] && eautoreconf
+ eautoreconf
}
src_configure() {
local myeconfargs=(
+ --without-benchmark
--disable-werror
$(use_enable python)
$(use_enable spreadsheet-model)
- $(use_enable static-libs static)
$(use_with tools)
)
econf "${myeconfargs[@]}"
@@ -57,5 +58,6 @@ src_configure() {
src_install() {
default
+ use python && python_optimize
find "${D}" -name '*.la' -type f -delete || die
}