summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-libs/liborcus')
-rw-r--r--dev-libs/liborcus/Manifest3
-rw-r--r--dev-libs/liborcus/liborcus-0.14.1-r1.ebuild57
-rw-r--r--dev-libs/liborcus/liborcus-0.19.2.ebuild (renamed from dev-libs/liborcus/liborcus-0.15.4.ebuild)29
-rw-r--r--dev-libs/liborcus/liborcus-9999.ebuild30
-rw-r--r--dev-libs/liborcus/metadata.xml2
5 files changed, 34 insertions, 87 deletions
diff --git a/dev-libs/liborcus/Manifest b/dev-libs/liborcus/Manifest
index 615d2489943a..43b43bede6f9 100644
--- a/dev-libs/liborcus/Manifest
+++ b/dev-libs/liborcus/Manifest
@@ -1,2 +1 @@
-DIST liborcus-0.14.1.tar.xz 1894680 BLAKE2B 0070baf319bf35275f36f3082141f154404ad43d8143588b35c00b8b536f0c1cf5bf38fd9e997c4be45a454f16de1cc1a25186da40e3ed0606a87e9a6a968053 SHA512 a32dc5a652ce99cff37273c38fb9460e13e7bfb562f40c8d0c79b65c33e340daaeeb2c796308ca700b85bfc13cc8215641563b9e9f6d44b7d61adb8e8a3c950f
-DIST liborcus-0.15.4.tar.xz 1590048 BLAKE2B b2edff8a00439154c2850e49fff151f59c0c5a43163cebe5cac84b627fcf87c89a0a522797d8a5bc39eaca9205d74ff3f0bdf9ba77561c5cc7aefe98f35a4c8b SHA512 edbe1d6f86a249e43915e7fb960e6b269fa8703e3f571a023e811dd3f9b5d9c9a36edff491faa7ed7ea3490bf5afe1999e26d05c658a0a393b3ffd08b311b76f
+DIST liborcus-0.19.2.tar.xz 2211268 BLAKE2B 4ee3fd2fb122d3a9840cb92452bf8a6d3d54b7b50a32be84e1bb08dfe2e2abc2de80098d9460b6bd82d0249304a7ba5c39b18ace3f69150ba71e16ef14795ca4 SHA512 c955490f57e91615278a83bb48726025cd5f8059b97ed5532f770199e134ca511c7ee6b0cd0a9d3a2d54208a5fdd19117054e95e818162ea568052fa11b21d4e
diff --git a/dev-libs/liborcus/liborcus-0.14.1-r1.ebuild b/dev-libs/liborcus/liborcus-0.14.1-r1.ebuild
deleted file mode 100644
index 1c14dc041dcd..000000000000
--- a/dev-libs/liborcus/liborcus-0.14.1-r1.ebuild
+++ /dev/null
@@ -1,57 +0,0 @@
-# Copyright 1999-2020 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=7
-
-PYTHON_COMPAT=( python3_{6,7,8} )
-inherit python-single-r1
-
-DESCRIPTION="Standalone file import filter library for spreadsheet documents"
-HOMEPAGE="https://gitlab.com/orcus/orcus/blob/master/README.md"
-
-if [[ ${PV} == *9999* ]]; then
- EGIT_REPO_URI="https://gitlab.com/orcus/orcus.git"
- inherit git-r3 autotools
-else
- SRC_URI="https://kohei.us/files/orcus/src/${P}.tar.xz"
- KEYWORDS="amd64 ~arm arm64 ~ppc ~ppc64 x86"
-fi
-
-LICENSE="MIT"
-SLOT="0/0.14" # based on SONAME of liborcus.so
-IUSE="python +spreadsheet-model static-libs tools"
-
-RDEPEND="
- dev-libs/boost:=[zlib(+)]
- sys-libs/zlib
- python? ( ${PYTHON_DEPS} )
- spreadsheet-model? ( dev-libs/libixion:${SLOT} )
-"
-DEPEND="${RDEPEND}
- =dev-util/mdds-1.4*:1
-"
-
-REQUIRED_USE="python? ( ${PYTHON_REQUIRED_USE} )"
-
-pkg_setup() {
- use python && python-single-r1_pkg_setup
-}
-
-src_prepare() {
- default
- [[ ${PV} == 9999 ]] && eautoreconf
-}
-
-src_configure() {
- econf \
- --disable-werror \
- $(use_enable python) \
- $(use_enable spreadsheet-model) \
- $(use_enable static-libs static) \
- $(use_with tools)
-}
-
-src_install() {
- default
- find "${D}" -name '*.la' -type f -delete || die
-}
diff --git a/dev-libs/liborcus/liborcus-0.15.4.ebuild b/dev-libs/liborcus/liborcus-0.19.2.ebuild
index 231fb4345b5b..8a3e66a9fe84 100644
--- a/dev-libs/liborcus/liborcus-0.15.4.ebuild
+++ b/dev-libs/liborcus/liborcus-0.19.2.ebuild
@@ -1,25 +1,30 @@
-# Copyright 1999-2020 Gentoo Authors
+# Copyright 1999-2024 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=7
+EAPI=8
-PYTHON_COMPAT=( python3_{6,7,8} )
-inherit python-single-r1
+PYTHON_COMPAT=( python3_{10..12} )
+inherit autotools python-single-r1
DESCRIPTION="Standalone file import filter library for spreadsheet documents"
HOMEPAGE="https://gitlab.com/orcus/orcus/blob/master/README.md"
if [[ ${PV} == *9999* ]]; then
+ MDDS_SLOT="1/3.0"
EGIT_REPO_URI="https://gitlab.com/orcus/orcus.git"
- inherit git-r3 autotools
+ inherit git-r3
else
+ MDDS_SLOT="1/2.1"
SRC_URI="https://kohei.us/files/orcus/src/${P}.tar.xz"
- KEYWORDS="amd64 ~arm arm64 ~ppc ~ppc64 ~x86"
+ KEYWORDS="amd64 ~arm arm64 ~loong ~ppc ppc64 ~riscv x86"
fi
LICENSE="MIT"
-SLOT="0/0.15" # based on SONAME of liborcus.so
-IUSE="python +spreadsheet-model static-libs tools"
+SLOT="0/0.18" # based on SONAME of liborcus.so
+IUSE="python +spreadsheet-model test tools"
+
+REQUIRED_USE="python? ( ${PYTHON_REQUIRED_USE} )"
+RESTRICT="!test? ( test )"
RDEPEND="
dev-libs/boost:=[zlib(+)]
@@ -28,18 +33,16 @@ RDEPEND="
spreadsheet-model? ( dev-libs/libixion:${SLOT} )
"
DEPEND="${RDEPEND}
- dev-util/mdds:1/1.5
+ dev-util/mdds:${MDDS_SLOT}
"
-REQUIRED_USE="python? ( ${PYTHON_REQUIRED_USE} )"
-
pkg_setup() {
use python && python-single-r1_pkg_setup
}
src_prepare() {
default
- [[ ${PV} == *9999 ]] && eautoreconf
+ eautoreconf
}
src_configure() {
@@ -47,7 +50,6 @@ src_configure() {
--disable-werror
$(use_enable python)
$(use_enable spreadsheet-model)
- $(use_enable static-libs static)
$(use_with tools)
)
econf "${myeconfargs[@]}"
@@ -55,5 +57,6 @@ src_configure() {
src_install() {
default
+ use python && python_optimize
find "${D}" -name '*.la' -type f -delete || die
}
diff --git a/dev-libs/liborcus/liborcus-9999.ebuild b/dev-libs/liborcus/liborcus-9999.ebuild
index 0ae4b1aa76b6..3aecf4036ad7 100644
--- a/dev-libs/liborcus/liborcus-9999.ebuild
+++ b/dev-libs/liborcus/liborcus-9999.ebuild
@@ -1,27 +1,30 @@
-# Copyright 1999-2020 Gentoo Authors
+# Copyright 1999-2024 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=7
+EAPI=8
-PYTHON_COMPAT=( python3_{6,7,8} )
-inherit python-single-r1
+PYTHON_COMPAT=( python3_{10..12} )
+inherit autotools python-single-r1
DESCRIPTION="Standalone file import filter library for spreadsheet documents"
HOMEPAGE="https://gitlab.com/orcus/orcus/blob/master/README.md"
if [[ ${PV} == *9999* ]]; then
- MDDS_SLOT="1/9999"
+ MDDS_SLOT="1/3.0"
EGIT_REPO_URI="https://gitlab.com/orcus/orcus.git"
- inherit git-r3 autotools
+ inherit git-r3
else
- MDDS_SLOT="1/1.5"
+ MDDS_SLOT="1/2.1"
SRC_URI="https://kohei.us/files/orcus/src/${P}.tar.xz"
- KEYWORDS="~amd64 ~arm ~arm64 ~ppc ~ppc64 ~x86"
+ KEYWORDS="~amd64 ~arm ~arm64 ~loong ~ppc ~ppc64 ~riscv ~x86"
fi
LICENSE="MIT"
-SLOT="0/0.16" # based on SONAME of liborcus.so
-IUSE="python +spreadsheet-model static-libs tools"
+SLOT="0/0.20" # based on SONAME of liborcus.so
+IUSE="python +spreadsheet-model test tools"
+
+REQUIRED_USE="python? ( ${PYTHON_REQUIRED_USE} )"
+RESTRICT="!test? ( test )"
RDEPEND="
dev-libs/boost:=[zlib(+)]
@@ -33,23 +36,21 @@ DEPEND="${RDEPEND}
dev-util/mdds:${MDDS_SLOT}
"
-REQUIRED_USE="python? ( ${PYTHON_REQUIRED_USE} )"
-
pkg_setup() {
use python && python-single-r1_pkg_setup
}
src_prepare() {
default
- [[ ${PV} == *9999 ]] && eautoreconf
+ eautoreconf
}
src_configure() {
local myeconfargs=(
+ --without-benchmark
--disable-werror
$(use_enable python)
$(use_enable spreadsheet-model)
- $(use_enable static-libs static)
$(use_with tools)
)
econf "${myeconfargs[@]}"
@@ -57,5 +58,6 @@ src_configure() {
src_install() {
default
+ use python && python_optimize
find "${D}" -name '*.la' -type f -delete || die
}
diff --git a/dev-libs/liborcus/metadata.xml b/dev-libs/liborcus/metadata.xml
index beb8258023d2..479b53c9f3db 100644
--- a/dev-libs/liborcus/metadata.xml
+++ b/dev-libs/liborcus/metadata.xml
@@ -1,5 +1,5 @@
<?xml version="1.0" encoding="UTF-8"?>
-<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<!DOCTYPE pkgmetadata SYSTEM "https://www.gentoo.org/dtd/metadata.dtd">
<pkgmetadata>
<maintainer type="project">
<email>office@gentoo.org</email>