summaryrefslogtreecommitdiff
path: root/dev-ml
diff options
context:
space:
mode:
Diffstat (limited to 'dev-ml')
-rw-r--r--dev-ml/tyxml/Manifest1
-rw-r--r--dev-ml/tyxml/tyxml-4.6.0.ebuild34
2 files changed, 35 insertions, 0 deletions
diff --git a/dev-ml/tyxml/Manifest b/dev-ml/tyxml/Manifest
index 6e7b8d531661..ee2302dbc275 100644
--- a/dev-ml/tyxml/Manifest
+++ b/dev-ml/tyxml/Manifest
@@ -1 +1,2 @@
DIST tyxml-4.5.0.tbz 102918 BLAKE2B 28c5f827e6969ce9557a86c976e6925716f30759607a11c027c9c6a63c6078437c84ec565d03a91775223fbb9bef97f7acc0c0bb5677205c7e0af7be601b6e26 SHA512 772535441b09c393d53c27152e65f404a0a541aa0cea1bda899a8d751ab64d1729237e583618c3ff33d75e3865d53503d1ea413c6bbc8c68c413347efd1709b3
+DIST tyxml-4.6.0.tbz 107055 BLAKE2B 51785927d3279ffcab940d42ff4de9a7d797ab7abf78bff80914db0355cb9f2f074310371d55abcb601595b461b718af8837c05fe6beca9b4988010526b6b5ff SHA512 69750eeaf467014282087bf9628f3278f3e5f00f4c7400358750d208664cfc3f79a5cba16767d2935e53477d1a6862fe08c5b801b69052ec12e09d1a93a5e9b4
diff --git a/dev-ml/tyxml/tyxml-4.6.0.ebuild b/dev-ml/tyxml/tyxml-4.6.0.ebuild
new file mode 100644
index 000000000000..0064acfb4d31
--- /dev/null
+++ b/dev-ml/tyxml/tyxml-4.6.0.ebuild
@@ -0,0 +1,34 @@
+# Copyright 2022-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit dune
+
+DESCRIPTION="A library for building correct HTML and SVG documents"
+HOMEPAGE="https://github.com/ocsigen/tyxml/"
+SRC_URI="https://github.com/ocsigen/${PN}/releases/download/${PV}/${P}.tbz"
+
+LICENSE="LGPL-2.1-with-linking-exception"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="+ocamlopt test"
+RESTRICT="!test? ( test )"
+
+RDEPEND="
+ dev-ml/markup:=
+ dev-ml/ppxlib:=
+ dev-ml/uutf:=
+ dev-ml/re:=
+"
+DEPEND="
+ ${RDEPEND}
+"
+BDEPEND="
+ test? (
+ dev-ml/alcotest
+ dev-ml/reason
+ )
+"
+
+PATCHES=( "${FILESDIR}"/${PN}-4.5.0-gentoo.patch )