summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-perl/Event/Event-1.270.0.ebuild')
-rw-r--r--dev-perl/Event/Event-1.270.0.ebuild29
1 files changed, 29 insertions, 0 deletions
diff --git a/dev-perl/Event/Event-1.270.0.ebuild b/dev-perl/Event/Event-1.270.0.ebuild
new file mode 100644
index 000000000000..719688225a8d
--- /dev/null
+++ b/dev-perl/Event/Event-1.270.0.ebuild
@@ -0,0 +1,29 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+DIST_AUTHOR=ETJ
+DIST_VERSION=1.27
+inherit perl-module
+
+DESCRIPTION="Fast, generic event loop"
+
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~ia64 ~ppc ~ppc64 ~sparc ~x86 ~x86-solaris"
+IUSE="test"
+RESTRICT="!test? ( test )"
+
+BDEPEND="
+ virtual/perl-ExtUtils-MakeMaker
+ test? (
+ >=virtual/perl-Test-1.0.0
+ )
+"
+src_compile() {
+ mymake=(
+ "OPTIMIZE=${CFLAGS}"
+ )
+ perl-module_src_compile
+}
+mydoc="ANNOUNCE INSTALL TODO Tutorial.pdf Tutorial.pdf-errata.txt"