summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-perl/Event')
-rw-r--r--dev-perl/Event/Event-1.270.0.ebuild29
-rw-r--r--dev-perl/Event/Manifest1
-rw-r--r--dev-perl/Event/metadata.xml3
3 files changed, 30 insertions, 3 deletions
diff --git a/dev-perl/Event/Event-1.270.0.ebuild b/dev-perl/Event/Event-1.270.0.ebuild
new file mode 100644
index 000000000000..719688225a8d
--- /dev/null
+++ b/dev-perl/Event/Event-1.270.0.ebuild
@@ -0,0 +1,29 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+DIST_AUTHOR=ETJ
+DIST_VERSION=1.27
+inherit perl-module
+
+DESCRIPTION="Fast, generic event loop"
+
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~ia64 ~ppc ~ppc64 ~sparc ~x86 ~x86-solaris"
+IUSE="test"
+RESTRICT="!test? ( test )"
+
+BDEPEND="
+ virtual/perl-ExtUtils-MakeMaker
+ test? (
+ >=virtual/perl-Test-1.0.0
+ )
+"
+src_compile() {
+ mymake=(
+ "OPTIMIZE=${CFLAGS}"
+ )
+ perl-module_src_compile
+}
+mydoc="ANNOUNCE INSTALL TODO Tutorial.pdf Tutorial.pdf-errata.txt"
diff --git a/dev-perl/Event/Manifest b/dev-perl/Event/Manifest
index a2c04a298d87..11c179534255 100644
--- a/dev-perl/Event/Manifest
+++ b/dev-perl/Event/Manifest
@@ -1 +1,2 @@
DIST Event-1.26.tar.gz 254787 BLAKE2B 9cac8633f38a674eefb91aa270d72541e216626f61d43cb638d8edb75da2fcf62c0586a40fb35888c2fbe8d0cee9cbb0c94efba0b38aaf124f574d867686ec9c SHA512 0ef22cbbecf01d98d7bddb46bcca48d888a0ed8a41d68165edfca54273e295b8ab53196f4a35fa45b440754f4e75024dbeb08be4daed16c2681506ce8cbdd474
+DIST Event-1.27.tar.gz 256609 BLAKE2B b27eff4243a0a009a6f97331359ec3bd2243c95e64f5ec8cd973fb1ec5f5732288bd7c906d2f97d2510f4595937ba0bf47461b12e0658540139058e3cc95d8ac SHA512 8b22723e200c490b3716245c4a08993e71fe475a95db50a91c71e5628efaa5855ec138b4a13c05bd21a08a0def6dc840c2a7947b1fbd53f84b37d9a9568a5bd1
diff --git a/dev-perl/Event/metadata.xml b/dev-perl/Event/metadata.xml
index d435fc3510cb..1a5954b24356 100644
--- a/dev-perl/Event/metadata.xml
+++ b/dev-perl/Event/metadata.xml
@@ -18,9 +18,6 @@
<remote-id type="cpan-module">Event::group</remote-id>
<remote-id type="cpan-module">Event::idle</remote-id>
<remote-id type="cpan-module">Event::io</remote-id>
- <remote-id type="cpan-module">Event::msg</remote-id>
- <remote-id type="cpan-module">Event::process</remote-id>
- <remote-id type="cpan-module">Event::semaphore</remote-id>
<remote-id type="cpan-module">Event::signal</remote-id>
<remote-id type="cpan-module">Event::timer</remote-id>
<remote-id type="cpan-module">Event::type</remote-id>