summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/cffi/cffi-1.15.1-r2.ebuild')
-rw-r--r--dev-python/cffi/cffi-1.15.1-r2.ebuild7
1 files changed, 6 insertions, 1 deletions
diff --git a/dev-python/cffi/cffi-1.15.1-r2.ebuild b/dev-python/cffi/cffi-1.15.1-r2.ebuild
index e3f103bdc292..36df28585ac8 100644
--- a/dev-python/cffi/cffi-1.15.1-r2.ebuild
+++ b/dev-python/cffi/cffi-1.15.1-r2.ebuild
@@ -4,11 +4,14 @@
# please keep this ebuild at EAPI 7 -- sys-apps/portage dep
EAPI=7
+# no py3.12 yet because of:
+# 1. https://foss.heptapod.net/pypy/cffi/-/issues/563
+# 2. https://foss.heptapod.net/pypy/cffi/-/issues/562
DISTUTILS_EXT=1
DISTUTILS_USE_PEP517=setuptools
# DO NOT ADD pypy to PYTHON_COMPAT
# pypy bundles a modified version of cffi. Use python_gen_cond_dep instead.
-PYTHON_COMPAT=( python3_{9..11} )
+PYTHON_COMPAT=( python3_{10..11} )
inherit distutils-r1 toolchain-funcs pypi
@@ -17,6 +20,7 @@ HOMEPAGE="
https://cffi.readthedocs.io/
https://pypi.org/project/cffi/
"
+SRC_URI+=" https://dev.gentoo.org/~sam/distfiles/${CATEGORY}/${PN}/${P}-drop-deprecated-py.patch.xz"
LICENSE="MIT"
SLOT="0/${PV}"
@@ -42,6 +46,7 @@ PATCHES=(
"${FILESDIR}"/cffi-1.14.0-darwin-no-brew.patch
"${FILESDIR}"/${P}-hppa.patch
"${FILESDIR}"/${P}-python3.11-tests.patch
+ "${WORKDIR}"/${P}-drop-deprecated-py.patch
)
src_prepare() {