summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python')
-rw-r--r--dev-python/cffi/Manifest1
-rw-r--r--dev-python/cffi/cffi-1.15.1-r2.ebuild7
2 files changed, 7 insertions, 1 deletions
diff --git a/dev-python/cffi/Manifest b/dev-python/cffi/Manifest
index 9418f03e5512..5682210b6d6b 100644
--- a/dev-python/cffi/Manifest
+++ b/dev-python/cffi/Manifest
@@ -1 +1,2 @@
+DIST cffi-1.15.1-drop-deprecated-py.patch.xz 31244 BLAKE2B 7c8a6ca1166335fbd385de35ebb636f21049a4dd9c52171ec58da08a61dc64c271b4afa2d69bf8b877a8c9747dfae6a8529615bbed69f5a8ab30ba5fc99c61f4 SHA512 9aba4b172b070a1a1719de2c35667abe4c7b27208b8ca3ecbf90bf168ed694f4524154e69fada5ff6f141a94b8a438db16239ba353fa9914b318b77e41dfd920
DIST cffi-1.15.1.tar.gz 508501 BLAKE2B accc317385d9af7dbed3397afde63fbab63bfc935376d951802055c63796863ed102a940f192789924480b9b16751c8cf3d21caf9b262c479c61ffc977aac83c SHA512 e99cafcb029076abc29e435b490fa0573ee2856f4051b7ca8a5b38cd125d56dd9dae8b189f59ceb3d728a675da8ee83239e09e19f8b0feeddea4b186ab5173a5
diff --git a/dev-python/cffi/cffi-1.15.1-r2.ebuild b/dev-python/cffi/cffi-1.15.1-r2.ebuild
index e3f103bdc292..36df28585ac8 100644
--- a/dev-python/cffi/cffi-1.15.1-r2.ebuild
+++ b/dev-python/cffi/cffi-1.15.1-r2.ebuild
@@ -4,11 +4,14 @@
# please keep this ebuild at EAPI 7 -- sys-apps/portage dep
EAPI=7
+# no py3.12 yet because of:
+# 1. https://foss.heptapod.net/pypy/cffi/-/issues/563
+# 2. https://foss.heptapod.net/pypy/cffi/-/issues/562
DISTUTILS_EXT=1
DISTUTILS_USE_PEP517=setuptools
# DO NOT ADD pypy to PYTHON_COMPAT
# pypy bundles a modified version of cffi. Use python_gen_cond_dep instead.
-PYTHON_COMPAT=( python3_{9..11} )
+PYTHON_COMPAT=( python3_{10..11} )
inherit distutils-r1 toolchain-funcs pypi
@@ -17,6 +20,7 @@ HOMEPAGE="
https://cffi.readthedocs.io/
https://pypi.org/project/cffi/
"
+SRC_URI+=" https://dev.gentoo.org/~sam/distfiles/${CATEGORY}/${PN}/${P}-drop-deprecated-py.patch.xz"
LICENSE="MIT"
SLOT="0/${PV}"
@@ -42,6 +46,7 @@ PATCHES=(
"${FILESDIR}"/cffi-1.14.0-darwin-no-brew.patch
"${FILESDIR}"/${P}-hppa.patch
"${FILESDIR}"/${P}-python3.11-tests.patch
+ "${WORKDIR}"/${P}-drop-deprecated-py.patch
)
src_prepare() {