summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/pipfile/pipfile-0.0.2.ebuild')
-rw-r--r--dev-python/pipfile/pipfile-0.0.2.ebuild26
1 files changed, 26 insertions, 0 deletions
diff --git a/dev-python/pipfile/pipfile-0.0.2.ebuild b/dev-python/pipfile/pipfile-0.0.2.ebuild
new file mode 100644
index 000000000000..356a0a84245d
--- /dev/null
+++ b/dev-python/pipfile/pipfile-0.0.2.ebuild
@@ -0,0 +1,26 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+PYTHON_COMPAT=( python2_7 python3_{5,6,7,8} pypy{,3} )
+
+inherit distutils-r1
+
+DESCRIPTION="Replacement for the existing standard pip's requirements.txt file"
+HOMEPAGE="https://github.com/pypa/pipfile"
+SRC_URI="https://github.com/pypa/pipfile/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="Apache-2.0 BSD-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+RDEPEND="dev-python/toml[${PYTHON_USEDEP}]"
+BDEPEND="${RDEPEND}
+ dev-python/setuptools[${PYTHON_USEDEP}]
+"
+
+# no tests in this release
+RESTRICT="test"
+
+# master has pytest tests
+distutils_enable_tests pytest