summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python')
-rw-r--r--dev-python/pipfile/Manifest1
-rw-r--r--dev-python/pipfile/metadata.xml12
-rw-r--r--dev-python/pipfile/pipfile-0.0.2.ebuild26
3 files changed, 39 insertions, 0 deletions
diff --git a/dev-python/pipfile/Manifest b/dev-python/pipfile/Manifest
new file mode 100644
index 000000000000..dbc117c4b7da
--- /dev/null
+++ b/dev-python/pipfile/Manifest
@@ -0,0 +1 @@
+DIST pipfile-0.0.2.tar.gz 17395 BLAKE2B ac86dc6a725cfec0e3d23cd24ab9cdbaa5c803b15916e03e6d2a1e371eb137e25836e78b3393bf6ac42c6d98ebf85fd4ccf29f63b8ab9b87cdd4828b3499278e SHA512 070986a213d0d42c3f5391b303ee0c4a588269ad1889c79b6622c1a9817cfcec4365b8764dcd208aafd78394890d3367c7c9782e65dd3f04ea1bcce001f164f1
diff --git a/dev-python/pipfile/metadata.xml b/dev-python/pipfile/metadata.xml
new file mode 100644
index 000000000000..f322c416621b
--- /dev/null
+++ b/dev-python/pipfile/metadata.xml
@@ -0,0 +1,12 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="project">
+ <email>python@gentoo.org</email>
+ <name>Python</name>
+ </maintainer>
+ <upstream>
+ <remote-id type="pypi">pipfile</remote-id>
+ <remote-id type="github">pypa/pipfile</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/dev-python/pipfile/pipfile-0.0.2.ebuild b/dev-python/pipfile/pipfile-0.0.2.ebuild
new file mode 100644
index 000000000000..356a0a84245d
--- /dev/null
+++ b/dev-python/pipfile/pipfile-0.0.2.ebuild
@@ -0,0 +1,26 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+PYTHON_COMPAT=( python2_7 python3_{5,6,7,8} pypy{,3} )
+
+inherit distutils-r1
+
+DESCRIPTION="Replacement for the existing standard pip's requirements.txt file"
+HOMEPAGE="https://github.com/pypa/pipfile"
+SRC_URI="https://github.com/pypa/pipfile/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="Apache-2.0 BSD-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+RDEPEND="dev-python/toml[${PYTHON_USEDEP}]"
+BDEPEND="${RDEPEND}
+ dev-python/setuptools[${PYTHON_USEDEP}]
+"
+
+# no tests in this release
+RESTRICT="test"
+
+# master has pytest tests
+distutils_enable_tests pytest