summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/pyjwt/pyjwt-2.0.1.ebuild')
-rw-r--r--dev-python/pyjwt/pyjwt-2.0.1.ebuild31
1 files changed, 31 insertions, 0 deletions
diff --git a/dev-python/pyjwt/pyjwt-2.0.1.ebuild b/dev-python/pyjwt/pyjwt-2.0.1.ebuild
new file mode 100644
index 000000000000..d6e6d2d94d3e
--- /dev/null
+++ b/dev-python/pyjwt/pyjwt-2.0.1.ebuild
@@ -0,0 +1,31 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python3_{7..9} )
+
+inherit distutils-r1 optfeature
+
+MY_PN="PyJWT"
+DESCRIPTION="JSON Web Token implementation in Python"
+HOMEPAGE="https://github.com/jpadilla/pyjwt/ https://pypi.org/project/PyJWT/"
+SRC_URI="mirror://pypi/${MY_PN:0:1}/${MY_PN}/${MY_PN}-${PV}.tar.gz"
+S="${WORKDIR}"/${MY_PN}-${PV}
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~ppc ~ppc64 ~sparc ~x86 ~amd64-linux ~x86-linux"
+
+RDEPEND=""
+DEPEND="
+ test? (
+ >=dev-python/cryptography-3.3.1[${PYTHON_USEDEP}]
+ )"
+
+distutils_enable_tests pytest
+
+pkg_postinst() {
+ elog "Available optional features:"
+ optfeature "cryptography" dev-python/cryptography
+}