summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python')
-rw-r--r--dev-python/pyjwt/Manifest1
-rw-r--r--dev-python/pyjwt/pyjwt-2.0.1.ebuild31
2 files changed, 32 insertions, 0 deletions
diff --git a/dev-python/pyjwt/Manifest b/dev-python/pyjwt/Manifest
index f6338047ad6a..0384aa0487a2 100644
--- a/dev-python/pyjwt/Manifest
+++ b/dev-python/pyjwt/Manifest
@@ -1,2 +1,3 @@
DIST PyJWT-1.7.1.tar.gz 41979 BLAKE2B 5604b309838b2dfb2f95e18e291c43703954664aa8acb7439072f002c1c8a1e49ff2c21d907be77a4d2f86e695ec71970d550aad2541252ac85bd7133e300b28 SHA512 70cd38127b6848933992c8b88303725ef71bfb430ad42eb63247e549b0bdab2a194137349d43ab02a1c97212dbc89f447ee3f0c5403dd14632b8b4b6b9235fc4
DIST PyJWT-2.0.0.tar.gz 56981 BLAKE2B e093bf23beb86a287e494018aed6bd6870d5923697b6502e4269f0b991b28c4ea6a53261b88789b0786b59e03b3d4eb763006becf0666921a81d0528c7677af5 SHA512 1831c93f100cd481e2ea80e23ff9f5114806cc493efc1c42ec6ff3ecc07e716d9ba2557b0b66fd8413946d166eebc1a44c453ec5407dfeef0529d222c9187e45
+DIST PyJWT-2.0.1.tar.gz 57496 BLAKE2B 1258734d2cd5ca6a4012691bef0ae2a7d6539083241cde7ef27da155cff0808211eddd56b9455e812bae4c739f83fed1c6fd84abcc85208203d86e5834d5952b SHA512 a59b975fb465b44e4d84e3ef0380ed5107438e202e073238700bd700e8871098b9c59a849d157ade7888eef32609078571e2b8af09dca0752d7a18c370c2a0a5
diff --git a/dev-python/pyjwt/pyjwt-2.0.1.ebuild b/dev-python/pyjwt/pyjwt-2.0.1.ebuild
new file mode 100644
index 000000000000..d6e6d2d94d3e
--- /dev/null
+++ b/dev-python/pyjwt/pyjwt-2.0.1.ebuild
@@ -0,0 +1,31 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python3_{7..9} )
+
+inherit distutils-r1 optfeature
+
+MY_PN="PyJWT"
+DESCRIPTION="JSON Web Token implementation in Python"
+HOMEPAGE="https://github.com/jpadilla/pyjwt/ https://pypi.org/project/PyJWT/"
+SRC_URI="mirror://pypi/${MY_PN:0:1}/${MY_PN}/${MY_PN}-${PV}.tar.gz"
+S="${WORKDIR}"/${MY_PN}-${PV}
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~ppc ~ppc64 ~sparc ~x86 ~amd64-linux ~x86-linux"
+
+RDEPEND=""
+DEPEND="
+ test? (
+ >=dev-python/cryptography-3.3.1[${PYTHON_USEDEP}]
+ )"
+
+distutils_enable_tests pytest
+
+pkg_postinst() {
+ elog "Available optional features:"
+ optfeature "cryptography" dev-python/cryptography
+}