summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/pyrqlite/pyrqlite-2.2.2.ebuild')
-rw-r--r--dev-python/pyrqlite/pyrqlite-2.2.2.ebuild30
1 files changed, 30 insertions, 0 deletions
diff --git a/dev-python/pyrqlite/pyrqlite-2.2.2.ebuild b/dev-python/pyrqlite/pyrqlite-2.2.2.ebuild
new file mode 100644
index 000000000000..ec12bed1b7aa
--- /dev/null
+++ b/dev-python/pyrqlite/pyrqlite-2.2.2.ebuild
@@ -0,0 +1,30 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{10..13} )
+inherit distutils-r1
+
+DESCRIPTION="Python client for rqlite"
+HOMEPAGE="
+ https://github.com/rqlite/pyrqlite/
+ https://pypi.org/project/pyrqlite/
+"
+SRC_URI="
+ https://github.com/rqlite/pyrqlite/archive/v${PV}.tar.gz
+ -> ${P}.gh.tar.gz
+"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+BDEPEND="
+ test? (
+ >=dev-db/rqlite-6.7.0
+ )
+"
+
+distutils_enable_tests pytest